Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] WebProtege and 3.4.1 login issue

Tania Tudorache tudorache at stanford.edu
Fri Jul 31 20:12:30 PDT 2009


This is strange. The only thing that I can suggest in this case is to 
debug it (MetaProjectManager.hasValidCredentials).

We have made in the last days some significant changes to webprotege to 
make it work with GWT 1.7 (structure of directories have changed, etc.).

Jennifer started to document the developers' guide for the new version here:

http://protegewiki.stanford.edu/index.php/WebProtegeDevelopersGuide

The new version is more robust and configurable, and it will run by 
default in local mode (not client-server mode) to make the life of 
developers easier (no more metaproject copying around). We will make a 
release for the new version next week.

If you can wait, I suggest to update to the new version once it is 
released, and this problem might go away.

Tania


Peter Ward wrote:
> Hello Tania
>
> I can log into the Protege server from the Protege thick client.
> I can browse ontologies in WebProtege without logging in.
> Any attempt to log in from WebProtege fails. There is no message in 
> the Protege server window. The protege log contains:
>
> 2009.07.30 11:47:17.213 BST INFO: *** SYSTEM START ***
> 2009.07.30 11:47:17.244 BST INFO: In AdminServiceImpl -- init -- 
> AdminServiceImpl.init()
> 2009.07.30 11:47:27.200 BST INFO: WebProtege server running with 
> remote projects loaded from the Protege server: localhost -- 
> ProjectManager.<init>()
> 2009.07.30 11:47:55.521 BST INFO: In init of OntologyServiceImp -- 
> OntologyServiceImpl.init()
> 2009.07.30 11:47:56.521 BST INFO: Loading project Collaborative Pizza 
> from Protege server localhost -- ProjectManager.openProjectRemote()
> 2009.07.30 11:48:03.288 BST WARNING: [Local Folder Repository] The 
> specified file must be a directory. 
> (D:\workspace\web-protege\plugins\edu.stanford.smi.protegex.owl) -- 
> LocalFolderRepository.update()
> 2009.07.30 11:48:03.351 BST CONFIG: Preloading frame values: 
> JenaOWLModel(KB_323587) -- RemoteClientFrameStore.preload()
> 2009.07.30 11:48:03.570 BST CONFIG: Preloading frame values: 
> DefaultKnowledgeBase(KB_895231) -- RemoteClientFrameStore.preload()
> 2009.07.30 11:48:09.243 BST CONFIG: Preloading frame values: 
> RDFKnowledgeBase(KB_861771) -- RemoteClientFrameStore.preload()
> 2009.07.30 11:48:09.275 BST CONFIG: Preloading frame values: 
> DefaultKnowledgeBase(KB_392397) -- RemoteClientFrameStore.preload()
> 2009.07.30 11:48:10.837 BST INFO: In init of ProjectConfigurationImpl 
> -- ProjectConfigurationServiceImpl.init()
> 2009.07.30 11:48:11.963 BST INFO: Path to project configuration file: 
> D:\workspace\web-protege\tomcat\webapps\ROOT\projectConfigurations\configuration.xml 
> -- ProjectConfigurationServiceImpl.getConfigurationFile()
>
> The server console ends with:
>
> Protege server ready to accept connections...
> Server: Adding Session(id=100, user=webprotege) on Thu Jul 30 11:47:59 
> BST 2009
> Server: Opened project Collaborative Pizza for Session(id=100, 
> user=webprotege)
> on Thu Jul 30 11:47:59 BST 2009
> Server: Adding Session(id=101, user=webprotege) on Thu Jul 30 11:48:09 
> BST 2009
> Server: Opened project Collaborative Pizza Annotations for 
> Session(id=101, user=
> webprotege) on Thu Jul 30 11:48:09 BST 2009
>
> I can't see anyother relevant logs (this is running hosted mode in 
> Eclipse). It's odd, as the data is clearly coming from the Protege 
> server using the webprotege login, but any other attempt fails. I am 
> convinced I have the right metaproject and have verified this by 
> changing passwords and observing password error from Protege client. 
> Can I turn on more debugging info on the client and server side??
>
> Peter
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03
>   




More information about the protege-discussion mailing list