Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] WebProtege Unable to Open Protege Project

Sittimont sittimont at yahoo.com
Thu Jun 11 23:40:09 PDT 2009


Bhaskar Ghosh <bjgindia <at> yahoo.co.in> writes:

> 
> 
> Hello Tania/All,
> NOTE: In continuation to this thread 
(https://mailman.stanford.edu/pipermail/protege-discussion/2009-
May/003204.html)
> 
> I am facing almost the same problem as Manolis faced (as described in the 
above thread chain). 
> I have created a new Protege Project (OWL/RDF Files) named
> proc_ontology.pprj. It is also displayed in the WebProtege that I have
> set up on my pc. 
> But, when I click it in WebProtege, I get a "Load project Pizza failed. 
Message: The call failed on the server; see server log for details" error.
> The error messages in the server log says, it was unable to open the
> project! I have pasted the Tomcat Server Logs at the end of this mail.
> I am also answering to the questions you had asked in the thread chain
> earlier.> 1. What Protege version you are using?PROTEGE 3.4 FULL VERSION> 2. 
Did the Protege server start successfully?YES>3. Did you create a 
user "webprotege" with the password "webprotege" in the metaproject? >This is 
how WebProtege connects to the Protege server. >If you didn't, then this is 
the problem. >Add the user "webprotege" to the group "World". >Make sure that 
the group World has read access to the Pizza project. >See: 
http://protegewiki.stanford.edu/index.php/Protege_Client_Server_Tutorial_Config
urationYES>4. Try to connect with a Protege client to the server, using the 
>user/pass: webprotege/webprotege and try to open project Pizza. Did you 
>succeed?I am unable to log in to the server using webprotege/webprotege. The 
Protege client
>  throws a "Failed to create a session because of either: an invalid 
username/password combination, ora firewall problem" error. But, I am sure I 
am entering webprotege/webprotege andthat this user/pwd combination is added 
to the metaproject.It is also the author of the proc_ontology project.>5. If 
you succeeded with all previous steps, but still has problems, >please send me 
the metaproject files and the a zip file with >catalina.out from the 
tomcat/logs folder.
> 
> -------------------------------TOMCAT SERVER LOGS----------------------------
---
> May 11, 2009 5:06:46 PM org.apache.catalina.core.ApplicationContext log
> SEVERE: Exception while dispatching incoming RPC call
> com.google.gwt.user.server.rpc.UnexpectedException: Service method
> 'public abstract java.lang.Integer
> edu.stanford.bmir.protege.web.client.rpc.OntologyService.loadProject
(java.lang.String)'
> threw an unexpected exception: java.lang.RuntimeException: Cannot open
> project proc_ontology
>     at com.google.gwt.user.server.rpc.RPC.encodeResponseForFailure
(RPC.java:360)
>     at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse
(RPC.java:546)
>     at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall
(RemoteServiceServlet.java:164)
>     at com.google.gwt.user.server.rpc.RemoteServiceServlet.doPost
(RemoteServiceServlet.java:86)
>     at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
>     at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
(ApplicationFilterChain.java:290)
>     at org.apache.catalina.core.ApplicationFilterChain.doFilter
(ApplicationFilterChain.java:206)
>     at org.apache.catalina.core.StandardWrapperValve.invoke
(StandardWrapperValve.java:233)
>     at org.apache.catalina.core.StandardContextValve.invoke
(StandardContextValve.java:191)
>     at org.apache.catalina.core.StandardHostValve.invoke
(StandardHostValve.java:128)
>     at org.apache.catalina.valves.ErrorReportValve.invoke
(ErrorReportValve.java:102)
>     at org.apache.catalina.core.StandardEngineValve.invoke
(StandardEngineValve.java:109)
>     at org.apache.catalina.connector.CoyoteAdapter.service
(CoyoteAdapter.java:286)
>     at org.apache.coyote.http11.Http11Processor.process
(Http11Processor.java:845)
>     at 
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process
(Http11Protocol.java:583)
>     at org.apache.tomcat.util.net.JIoEndpoint$Worker.run
(JIoEndpoint.java:447)
>     at java.lang.Thread.run(Thread.java:619)
> Caused by: java.lang.RuntimeException: Cannot open project proc_ontology
>     at edu.stanford.bmir.protege.web.server.ProjectManager.ensureProjectOpen
(Unknown Source)
>     at edu.stanford.bmir.protege.web.server.ProjectManager.getServerProject
(Unknown Source)
>     at edu.stanford.bmir.protege.web.server.OntologyServiceImpl.loadProject
(Unknown Source)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java:39)
>     at sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAccessorImpl.java:25)
>     at java.lang.reflect.Method.invoke(Method.java:597)
>     at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse
(RPC.java:527)
>     ... 16 moreThanks in advance.
> 
> Bhaskar"Ignorance is Bliss... Knowledge never brings Peace!!!"
> 
> 
>  Explore your hobbies and interests. Click here to begin.
> 
> 
> _______________________________________________
> protege-discussion mailing list
> protege-discussion <at> lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
> 
> Instructions for unsubscribing: 
http://protege.stanford.edu/doc/faq.html#01a.03 
> 








Hi Tania/All

   I have faced the problem with loading my ontology onto the WebProtege which 
is not quite the same with this post but similar.

-Protege Client/Server working with user webprotege and can load default 
ontologies and new ones in protege. (new projects metadata added)
-However when starting server script .bat, it shows up with:

Updating underlying frames model in 0 ms
WARNING: Unknown class: CaseRating - Project.loadWidgetDescriptors<>
WARNING: Unknown class: comments_about_parts - Project.loadWidgetDescriptors<>
WARNING: Unknown class: TemperatureClass - Project.loadWidgetDescriptors<>
WARNING: Unknown class: Clients - Project.loadWidgetDescriptors<>

In effect the project does not show up in web protégé.

I think thats a rough outline of problem? :(


Could you please advise?

Regards
Sittimont








More information about the protege-discussion mailing list