Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] [Plugin Problems] Updating from 3.3.1 to 3.4

Vasco Costa hypept at gmail.com
Thu May 21 10:25:07 PDT 2009


Hi,

I'm a student from Portugal working on a research project which envolves the
creation of a Protégé plugin.

I used the Protégé 3.3.1 *.JAR files in my project and everything worked
fine.

Then I came across the new 3.4 version and tried to replace the old 3.3.1
files and I got this error while debugging:

"Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError:
org/protege/editor/owl/model/hierarchy/roots/Relation
        at
edu.stanford.smi.protegex.owl.jena.parser.TripleProcessor.<init>(Unknown
Source)
        at
edu.stanford.smi.protegex.owl.jena.parser.GlobalParserCache.getTripleProcessor(Unknown
Source)
        at
edu.stanford.smi.protegex.owl.jena.parser.ProtegeOWLParser.loadTriples(Unknown
Source)
        at
edu.stanford.smi.protegex.owl.jena.parser.ProtegeOWLParser.run(Unknown
Source)
        at
edu.stanford.smi.protegex.owl.jena.JenaKnowledgeBaseFactory.loadKnowledgeBase(Unknown
Source)
(...)"

The error log goes on, but is very large.

Can anyone help?

Thanks.

Vasco
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20090521/ee1edfe2/attachment.html>


More information about the protege-discussion mailing list