Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] [Plugin Problems] Updating from 3.3.1 to 3.4

Tania Tudorache tudorache at stanford.edu
Thu May 21 18:07:25 PDT 2009


You are missing the orphanNode.jar for protege-owl plugin folder in your 
classpath.

Tania

Vasco Costa wrote:
> Hi,
>
> I'm a student from Portugal working on a research project which 
> envolves the creation of a Protégé plugin.
>
> I used the Protégé 3.3.1 *.JAR files in my project and everything 
> worked fine.
>
> Then I came across the new 3.4 version and tried to replace the old 
> 3.3.1 files and I got this error while debugging:
>
> "Exception in thread "AWT-EventQueue-0" 
> java.lang.NoClassDefFoundError: 
> org/protege/editor/owl/model/hierarchy/roots/Relation
>         at 
> edu.stanford.smi.protegex.owl.jena.parser.TripleProcessor.<init>(Unknown 
> Source)
>         at 
> edu.stanford.smi.protegex.owl.jena.parser.GlobalParserCache.getTripleProcessor(Unknown 
> Source)
>         at 
> edu.stanford.smi.protegex.owl.jena.parser.ProtegeOWLParser.loadTriples(Unknown 
> Source)
>         at 
> edu.stanford.smi.protegex.owl.jena.parser.ProtegeOWLParser.run(Unknown 
> Source)
>         at 
> edu.stanford.smi.protegex.owl.jena.JenaKnowledgeBaseFactory.loadKnowledgeBase(Unknown 
> Source)
> (...)"
>
> The error log goes on, but is very large.
>
> Can anyone help?
>
> Thanks.
>
> Vasco
> ------------------------------------------------------------------------
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
>   




More information about the protege-discussion mailing list