Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Problem using older projects in Protege 3.4

Hanno Wunderlich hannowun at googlemail.com
Fri May 22 04:46:43 PDT 2009


Hi,

it really was a plugin-issue. The plugin (created for a different ontology)
tried to make a refactoring which gave theese errors.

Thanks for your help

Hanno

On Fri, May 22, 2009 at 3:38 AM, Tania Tudorache <tudorache at stanford.edu>wrote:

> I could not reproduce the problem.. It seems like this is a problem
> either with your Protege 3.3.1 installation (maybe a plugin going
> rogue), or your Protege 3.4 installation.
>
> Did you install any additional plugins in P3.3.1 or P3.4?
>
> I did the exact steps you described and did not get the error. It is
> also possible that your ontology has some problem. If you can, please
> send us the ontology, and we can take a look what is going wrong.
>
> We will have Memorial day holiday starting with this Friday and be back
> only on Tuesday next week.
>
> Tania
>
>
> Hanno Wunderlich wrote:
> > Hi,
> >
> > i am moving my old protege projects to protege 3.4 in order to use the
> > new features (especially these in the server part). But when i load
> > and save one of my old projects with protege 3.4 i get following
> > warnings for all slots and clses:
> >
> > WARNING: null type: my_Cls1 -- InstanceStorer.isStorableInstance()
> > WARNING: null type: my_Slot1 -- InstanceStorer.isStorableInstance()
> >
> >
> > After saving all the class-instances were removed from the
> > :STANDARD-CLASS as well as the slot-instance from the :STANDARD-SLOT.
> > But when i restart protege with the saved project the clses and slots
> > are there again (and the warnings occur again when saving).
> >
> > The Problem can be reproduced as follows:
> > - create a new project with protege 3.3.1
> > - create a new cls a in the project
> > - create a new slot b in the project
> > - save the project
> > - load the project in protege 3.4
> > - save the project
> >
> > You will get:
> > WARNING: null type: a -- InstanceStorer.isStorableInstance()
> > WARNING: null type: b -- InstanceStorer.isStorableInstance()
> >
> > Is there any way to correct the project so that protege 3.4 will not
> > post the warnings?
> >
> > Thanks
> > Hanno
> >
> >
> >
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > protege-discussion mailing list
> > protege-discussion at lists.stanford.edu
> > https://mailman.stanford.edu/mailman/listinfo/protege-discussion
> >
> > Instructions for unsubscribing:
> http://protege.stanford.edu/doc/faq.html#01a.03
> >
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing:
> http://protege.stanford.edu/doc/faq.html#01a.03
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20090522/caa9c739/attachment.html>


More information about the protege-discussion mailing list