Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Server problem and Ontology list won't display

Natsuda Kasisopha gift8201 at gmail.com
Thu Oct 1 01:18:32 PDT 2009


Hi again Jennifer,

I'm really sorry for the confusion. The server admin created so many alias
path, /usr/local/tomcat5 is actually point to
/usr/local/apache-tomcat-5.5.26.

I had place a new copy of the webprotege.war in the webapps from your
advice. Now my protege.property looks like below:

#Protege Properties
#Wed Sep 30 13:57:39 WST 2009
load.ontologies.from.protege.server=false
webprotege.password=webprotege
webprotege.user=webprotege
server.hostname=localhost
history.projects.reopen=file\:/srv/www/webapps/webprotege/examples/newspaper/newspaper.pprj,file\:/srv/www/webapps/webprotege/examples/pizza/pizza.owl.pprj,file\:/srv/www/webapps/webprotege/examples/collaborativePizza/collaborativePizza.owl.pprj
server.save.interval.sec=120

my server logs:

30-Sep-2009 13:54:03 org.apache.catalina.startup.HostConfig checkResources
INFO: Reloading context [/webprotege]
30-Sep-2009 13:54:03 org.apache.catalina.core.StandardWrapper unload
INFO: Waiting for 1 instance(s) to be deallocated
30-Sep-2009 13:54:04 org.apache.catalina.core.StandardWrapper unload
INFO: Waiting for 1 instance(s) to be deallocated
30-Sep-2009 13:54:05 org.apache.catalina.core.StandardWrapper unload
INFO: Waiting for 1 instance(s) to be deallocated
30-Sep-2009 13:56:55 org.apache.catalina.startup.HostConfig checkResources
INFO: Reloading context [/webprotege]
30-Sep-2009 13:57:39 edu.stanford.bmir.protege.web.server.AdminServiceImpl
init
INFO: WebProtege running in: /usr/local/tomcat5/webapps/webprotege/
30-Sep-2009 13:57:39 edu.stanford.smi.protege.plugin.PluginUtilities
findPluginsDirectory
WARNING: Plugins directory not found:
/usr/local/tomcat5/webapps/webprotege/plugins
30-Sep-2009 13:57:39 edu.stanford.smi.protege.resource.BundleHelper <init>
WARNING: missing bundle: standard_extensions_text
30-Sep-2009 13:57:39 edu.stanford.smi.protege.resource.BundleHelper
internalGetText
WARNING: no resource bundle: tab.queries
30-Sep-2009 13:57:39 edu.stanford.smi.protege.plugin.PluginUtilities
isLoadableClass
WARNING: java.lang.NoClassDefFoundError: com/nwoods/jgo/JGoView
30-Sep-2009 13:57:39
edu.stanford.bmir.protege.web.server.ApplicationProperties
getLocalMetaprojectURI
INFO: Path to local metaproject:
/usr/local/tomcat5/webapps/webprotege/projects/metaproject/metaproject.pprj
30-Sep-2009 13:57:40 edu.stanford.bmir.protege.web.server.ProjectManager
<init>
INFO: WebProtege server running with local projects
30-Sep-2009 13:57:40
edu.stanford.bmir.protege.web.server.LocalMetaProjectManager getProjectsData
INFO: Found project def in metaproject: Newspaper at:
projects/newspaper/newspaper.pprj
30-Sep-2009 13:57:40
edu.stanford.bmir.protege.web.server.LocalMetaProjectManager getProjectsData
INFO: Found project def in metaproject: Collaborative Pizza at:
projects/collaborativePizza/collaborativePizza.owl.pprj
30-Sep-2009 13:57:40
edu.stanford.bmir.protege.web.server.LocalMetaProjectManager getProjectsData
INFO: Found project def in metaproject: Collaborative Newspaper at:
projects/collaborativeNewspaper/collaborativeNewspaper.pprj
30-Sep-2009 13:57:40
edu.stanford.bmir.protege.web.server.LocalMetaProjectManager getProjectsData
INFO: Found project def in metaproject: Wines at: projects/wines/wines.pprj
30-Sep-2009 13:57:40
edu.stanford.bmir.protege.web.server.LocalMetaProjectManager getProjectsData
INFO: Found project def in metaproject: Pizza at:
projects/pizza/pizza.owl.pprj

Best Regards,
Natsuda

2009/10/1 Jennifer Vendetti <vendetti at stanford.edu>

>  Hello Nat,
>
> There are some inconsistencies I noticed with the image and log file you
> sent us:
>
> 1).  The servePath.bmp image file shows the Tomcat directory as
> /usr/local/apache-tomcat-5.5.26.  However, the log file you sent shows
> WebProtege running in /usr/local/tomcat5/, i.e.:
>
> INFO: WebProtege running in: /usr/local/tomcat5/webapps/webprotege/
>
> This leads me to believe that you haven't sent us the right log file.
>
> 2).  The protege.properties file you sent below shows that you have
> configured WebProtege to load projects from a Protege server, i.e., *
> load.ontologies.from.protege.server=true*.  If WebProtege can't load
> projects from the server, your log file would have a message in it that
> looks something like the following:
>
> SEVERE: Could not connect to server: (your-server-name-here)
> WARNING: Could not get remote projects. Reason: Cannot connect to remote
> server.
>
> The log file you sent indicates that WebProtege is not using the Protege
> server (the actual protege.properties file WebProtege is using has *
> load.ontologies.from.protege.server=false*), as shown by:
>
> INFO: WebProtege server running with local projects
>
> Here are some steps that you could use to send us the correct files we need
> to debug the problem:
>
> 1).  Shut down Tomcat.
> 2).  Delete the webprotege directory and webprotege.war file from the
> webapps directory.
> 3).  Place a new copy of the webprotege.war file in the webapps directory.
> 4).  Start Tomcat.
> 5).  After the webprotege directory is unpacked (i.e. appears underneath
> the webapps directory), try to access WebProtege from a browser.
> 6).  Send us the log file from the /usr/local/apache-tomcat-5.5.26/logs
> directory and the protege.properties file from the webapps/webprotege/
> directory.  Please check the date on the log file to confirm that it has new
> content in it since you accessed WebProtege in step 4.
>
> Jennifer
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20091001/f868a173/attachment.html>


More information about the protege-discussion mailing list