Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Ontology list won't display

Natsuda Kasisopha gift8201 at gmail.com
Fri Oct 2 11:10:29 PDT 2009


Hi Timothy,

Thanks for you reply. In the previous email said that the URL 
"http://natsuda.tomcat.debii.curtin.edu.au/ 
<http://natsuda.tomcat.debii.curtin.edu.au/>"  is alias that are the 
same with "http://localhost:8080/webprotege/ 
<http://localhost:8080/webprotege/>" but without state the "webprotege" 
in its path. If I put URL 
"http://natsuda.tomcat.debii.curtin.edu.au/webprotege" 
<http://natsuda.tomcat.debii.curtin.edu.au/>, the web page will look 
like this




If I used the URL http://natsuda.tomcat.debii.curtin.edu.au/ 
<http://natsuda.tomcat.debii.curtin.edu.au/> , the web page appears 
(please refer to the picture below).
 


And if you want the real URL, I have to ask the server administrator and 
get back to you soon.

"You should be able to simply upload the war file to the webapps 
directory and tomcat will expand the war file itself.  If this is not 
happening then somehow you are deploying to the wrong place."

 From your quote, I don't understand that if the tomcat doesn't expand 
the war file itself, then I am deploying to the wrong place. But how 
come the "WebProtege.html" can display on the browser?

I just try to have the ontology list display with the WebProtege.html page.

Thanks you,
Natsuda



Timothy Redmond wrote:
>
>> Sorry for the confusion and frustration on my problem. I'm no 
>> different from you. You were talking about the URL of my web site 
>> "http://natsuda.tomcat.debii.curtin.edu.au/" and how did the 
>> "webprotege" didn't appears on the URL, the URL of 
>> "http://natsuda.tomcat.debii.curtin.edu.au/"  is another alias that 
>> equivalence to "http://localhost:8080/webprotege/" but different host 
>> name.
>
> So this might be the key.  An important question is what happens when 
> you access tomcat directly with
>
>     http://localhost:8080/webprotege
>
> on the different host.
>
>> According to your instruction and the instruction in the wiki, the 
>> Tomcat suppose to unzip the "webprotege.war" automatically but the 
>> winSCP doesn't do that. Thus I unzip the file on my computer and then 
>> upload them to the server.
>
> You should be able to simply upload the war file to the webapps 
> directory and tomcat will expand the war file itself.  If this is not 
> happening then somehow you are deploying to the wrong place.
>
> -Timothy
>
> On Oct 2, 2009, at 5:16 AM, Natsuda Kasisopha wrote:
>
>> Dear Jennifer,
>>
>> Sorry for the confusion and frustration on my problem. I'm no 
>> different from you. You were talking about the URL of my web site 
>> "http://natsuda.tomcat.debii.curtin.edu.au/" and how did the 
>> "webprotege" didn't appears on the URL, the URL of 
>> "http://natsuda.tomcat.debii.curtin.edu.au/"  is another alias that 
>> equivalence to "http://localhost:8080/webprotege/" but different host 
>> name. If you put 
>> "http://natsuda.tomcat.debii.curtin.edu.au/webprotege/WebProtege.html", 
>> it would appear Error message "HTTP Status 404  - 
>> /webprotege/webprotege/WebProtege.html". This has shown that the URL 
>> "http://natsuda.tomcat.debii.curtin.edu.au/" already pointing to  
>> "webapps/webprotege/WebProtege.html" just like  
>> "http://localhost:8080/webprotege/" path.
>>
>> On your request of how am I deployed the Web Protege on the server. 
>> First of all, I'm using a shared server (host) name 
>> "blade1.debii.curtin.edu.au" of the institute that I am studying at. 
>> I access the server remotely by using winSCP. I don't have the direct 
>> access to the server. According to your instruction and the 
>> instruction in the wiki, the Tomcat suppose to unzip the 
>> "webprotege.war" automatically but the winSCP doesn't do that. Thus I 
>> unzip the file on my computer and then upload them to the server. The 
>> directory path on the server, the server administrator manage and 
>> provide for me. I'm only allow to modify/delete the content in 
>> webprotege folder.
>>
>> I notice in the log file i sent you. There were a fill Warning about 
>> the "plugins" directory, please refer to the message below. Is this 
>> directory need for the Web Protege page?
>> WARNING: Plugins directory not found: 
>> /usr/local/tomcat5/webapps/webprotege/plugins
>> 30-Sep-2009 13:57:39 edu.stanford.smi.protege.resource.BundleHelper 
>> <init>
>>
>> WARNING: Plugins directory not found: 
>> /usr/local/tomcat5/webapps/webprotege/plugins
>> 30-Sep-2009 13:57:39 edu.stanford.smi.protege.resource.BundleHelper 
>> <init>
>>
>> I hope the information I give would help.
>> Nat
>>
>> Jennifer Vendetti wrote:
>>> Hello Natsuda,
>>>
>>> We are trying to reproduce your problem here, but have been 
>>> unsuccessful so far.  One question we have is how you managed to 
>>> configure your server such that there is no "webprotege" in the path 
>>> to the WebProtege application.  In other words, you sent us the URL 
>>> of "http://natsuda.tomcat.debii.curtin.edu.au/", which launches 
>>> WebProtege.  But, if we run WebProtege using the standard way of 
>>> deploying the WAR file to Tomcat, we end up with a URL that looks 
>>> like this: http://localhost:8080/webprotege/.  One possibility is 
>>> that the aliases that your admin has set up is somehow preventing 
>>> WebProtege from finding the projects that are listed in the 
>>> metaproject.  But, we are having trouble reproducing your particular 
>>> deployment scenario.  Are there any more details you can give us 
>>> about how you set up your deployment - in particular, how did you 
>>> eliminate the "webprotege" portion of the path?
>>>
>>> Jennifer
>> _______________________________________________
>> protege-discussion mailing list
>> protege-discussion at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>>
>> Instructions for unsubscribing: 
>> http://protege.stanford.edu/doc/faq.html#01a.03
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: 
> http://protege.stanford.edu/doc/faq.html#01a.03
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20091003/dedcb848/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: moz-screenshot.jpg
Type: image/jpeg
Size: 49054 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20091003/dedcb848/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: moz-screenshot-2.jpg
Type: image/jpeg
Size: 37024 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20091003/dedcb848/attachment-0001.jpg>


More information about the protege-discussion mailing list