Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Randomly no displayslots in Protege Client-Server-Mode until server restart.

Timothy Redmond tredmond at stanford.edu
Thu Nov 4 13:06:29 PDT 2010


On 11/04/2010 06:35 AM, Hanno Wunderlich wrote:
> Hi,
>
> i want to re-push my problem, as nobody has replied yet.
>

Good - I think that we must have lost track of this e-mail.  This is a 
tricky question so part of the problem is that people who did see this 
the first time might have gotten stuck.

The one thing that is a bit unusual about your set up is that you are 
hosting projects that include one another.  I can't see a reason why 
this would create problems though.   I am guessing that the including 
projects don't see changes made to the included projects in real time?

>
> Or is there a way to reload only one particular project (or its 
> display slots) on the server, so that all other users can continue 
> their work?

This is the one part of this question that is very easy to answer.  Yes 
you can do this (if you are using a relatively recent version of Protege).

When you connect to the server there is an option in the login screen 
asking if you want to administrate the server.  You need to have 
administrative access to do this but this will give you some very useful 
controls over the server.  You can stop and start projects, monitor 
users and change the metaproject without shutting the server down.

-Timothy



> We are now observing this problem 2-3 times a week. As the only 
> workaround is to restart the server (which needs all users to log off 
> and have a ~20 minutes break) we really need a fix for that.
>
> So again, what would be the best way to track down what is happening 
> on the server when loading the display slots.
>
> Regards,
> Hanno Wunderlich
>
> PS: Is there any bug-tracker where Bugs for Protege are filed?
> PPS: Where would be the best place to post suggestions for new 
> features for Protege?
>
> On Tue, Oct 5, 2010 at 12:14 PM, Hanno Wunderlich 
> <hannowun at googlemail.com <mailto:hannowun at googlemail.com>> wrote:
>
>     Hi,
>
>     we are using Protege Frames (3.4) in Client-Server-Mode with
>     following project setup:
>
>     Project A : Contains only Classes and Slots and formular
>     informations (including displayslots)
>     Project B: Includes project A, contains some instances
>     Project C: Includes project A, contains some instances, contains
>     own formular informations (including displayslots)
>     Project D: Includes project C, contains some instance, contains
>     own formular informations for two classes
>
>     Project B,C,D are hosted on our Protege server. All projects were
>     stored in clips files.
>
>     Durinig usage of theese projects we are randomly observing that
>     clients connecting to a project can load and view it, but the
>     defined display slots are missing (the default display slot
>     ...Instance_XXXXXXX is used). After observing this problem and
>     reconnecting to the same project (even from another client) the
>     display slots are still wrong. The only thing, that solves the
>     problem is restarting the server.
>
>     The interesting thing is, that if the display slots for project C
>     were wrong that does not mean that they are also wrong when
>     connecting to project B or D.
>
>     As multiple users are accessing the different projects at the same
>     time we can't always restart the server if one project shows the
>     wrong display slots.
>
>     Is there a way to track down, why this is happening? E.g. what
>     logging.properties should be used.
>
>     Or is there a way to reload only one particular project (or its
>     display slots) on the server, so that all other users can continue
>     their work?
>
>     Regards,
>
>     Hanno Wunderlich
>
>     PS: Only the display slots seem to be affected. The forms are
>     always loaded as expected.
>
>
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20101104/07e28a86/attachment.html>


More information about the protege-discussion mailing list