Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Why my applet can't run in explore

Timothy Redmond tredmond at stanford.edu
Sat Oct 16 20:14:15 PDT 2010


You are getting into more difficult errors. Is there no other caused by
further down in the stack trace? It can be difficult to get an applet
working because the policy for applets is pretty stringent.

-Timothy




On 10/15/2010 05:44 PM, 刘康 wrote:
> Hi, thank your help.
> I have put the jena.jar and pellet.jar on the dictionary, and add them
> to the "archive=...". It seem the pakage is ok now, but the errors
> exist remain as follow:
> ----------------------------------------------------
>
> java.lang.RuntimeException: java.lang.ExceptionInInitializerError
>
> at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
>
> at
> sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown
> Source)
>
> at java.lang.Thread.run(Unknown Source)
>
> Caused by: java.lang.ExceptionInInitializerError
>
> at
> com.hp.hpl.jena.rdf.model.ModelFactory.createDefaultModel(ModelFactory.java:119)
>
> at
> com.hp.hpl.jena.rdf.model.ModelFactory.createDefaultModel(ModelFactory.java:113)
>
> at
> com.hp.hpl.jena.rdf.model.impl.ModelSpecImpl.<clinit>(ModelSpecImpl.java:56)
>
> at
> org.mindswap.pellet.jena.PelletReasonerFactory.<clinit>(PelletReasonerFactory.java:51)
>
> at JenaOWL.JenaOWLTool.<init>(JenaOWLTool.java:43)
>
> at JenaOWL.FuncJenaOWL.<init>(FuncJenaOWL.java:11)
>
> ........
> -------------------------------------------------------
> According to the errors, the jena's createDefaultModel, or the
> ModelFactory is not work. I don't know why? It works ok in eclipse. I
> use the pellet-1.4-RC1, and the package of pellet.jar is the one of in
> it's pellet-1.4-RC1/lib, the jena.jar is the one of in the
> pellet-1.4-RC1/lib/jena. Is there any mistake?
>
> 在 2010年10月15日 下午11:08,Timothy Redmond <tredmond at stanford.edu
> <mailto:tredmond at stanford.edu>>写道:
>
>     On 10/15/2010 07:47 AM, 刘康 wrote:
>>     I have write a OWL applet with jena and pellet, it works in the
>>     eclipse, but can't do in explore.The error's imformations as bellow:
>>
>     You have some type of configuration problem in your applet. The
>     jena jar is not on the classpath. Debugging applets can be
>     difficult actually but in this case you are doing well because you
>     see the exception.
>
>     -Timothy
>
>
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03
>   

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20101016/706883cf/attachment.html>


More information about the protege-discussion mailing list