Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Problem with WebProtege Notes & Discussions Tool

Astrid Rheinländer astrid.rheinlaender at novartis.com
Tue Sep 7 05:40:16 PDT 2010


Tania Tudorache <tudorache <at> stanford.edu> writes:

> 
> Hi Astrid,
> 
> The warnings are fine, you can ignore them. They say that the annotation
ontology used for storing the notes
> and change tracking has on older version, and that the archiving will not work.
> 
> It seems like you are using the local mode, not the external server mode [1],
right?
> 
> In which of the projects did you try to create a note? The notes only work in
the projects that have the
> annotation project configured, e.g. Collaborative Pizza.
> 
> If you added your own project in the metaproject and want to enable the notes,
then you need to associate to
> the project the annotation project (one time configuration). The steps are
described in the Multi user
> mode here [2].
> 
> Tania
> 
> [1]:http://protegewiki.stanford.edu/wiki/WebProtegeAdminGuide
> [2]: http://protegewiki.stanford.edu/wiki/Collaborative_Protege#Multi-user_mode

Hi Tania,

you are right, I'm using the local mode, and I tried to create notes in the
Collaborative Pizza project and didn't change anything in the config files. 

So here is what I did, maybe you can reproduce the error:

1. I clicked on some node in the Classes Tree and then on the right side on "new
topic" in the NotesTree Portlet.

2. Entered my comment in the popup window and clicked "send". The comment
appears now in the NotesTree.

3. I clicked on some other node in the Classes Tree and then switched back to
the first node where I entered my comment

4. Now, I can see two small bubbles next to this node that indicate that there
is a comment. But when I click on this bubble, I can't see my comment and the
NotesTree is empty again. 

It seems to me as if this is caused by a bug in the GUI, since the comment is
stored in "annotation_collaborativePizza.owl.rdf"

<kb:Ontology_Class rdf:about="&kb;annotation_collaborativePizza.owl_Class10014">
       
<kb:currentName>http://www.co-ode.org/ontologies/pizza/2005/10/18/pizza.owl#SpicyTopping</kb:currentName>
       
<rdfs:label>http://www.co-ode.org/ontologies/pizza/2005/10/18/pizza.owl#SpicyTopping</rdfs:label>
        <kb:associatedAnnotations
rdf:resource="&kb;annotation_collaborativePizza.owl_Class10015"/>
</kb:Ontology_Class>
<kb:Advice rdf:about="&kb;annotation_collaborativePizza.owl_Class10015"
         kb:author="Admin"
         kb:body=""
         kb:subject="this is a test"
         rdfs:label="this is a test">
        <kb:annotates
rdf:resource="&kb;annotation_collaborativePizza.owl_Class10014"/>
        <kb:created
rdf:resource="&kb;annotation_collaborativePizza.owl_Class10016"/>
</kb:Advice>
<kb:Timestamp rdf:about="&kb;annotation_collaborativePizza.owl_Class10016"
         kb:date="09/07/2010 14:15:59 CEST"
         kb:sequence="6"
         rdfs:label="09/07/2010 14:15:59 CEST"/>

Thanks for your help.
Astrid






More information about the protege-discussion mailing list