Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Protege-core and Protege-frame right version?

Matteo Dany teo.malefico at gmail.com
Tue Sep 21 09:05:35 PDT 2010


Hi everybody,

I have installed Protege 4.1 to edit an ontology in OWL2.
Now I'll want use the API of Protege, but I have a doubt about the version
and how use the reasoner runs on localhost runExample(owlModel,
createDIGReasoner(owlModel)) .

I have downloaded and installed these couple of components:

           --Protege-core
                      svn co
http://smi-protege.stanford.edu/repos/protege/protege-core/trunk

           --Protege-owl
                      svn co
http://smi-protege.stanford.edu/repos/protege/owl/trunk

and more I've compiled Protege Pellet .

The doubt is about the version that is 3.4.etc. Is the leastest API version?
Must I  download from other URL?

However I've tried to compile ProtegeReasonerExample (I've found the example
in the Wiki).

When run the program there is the a issue: Reasoner not connected =>
runExample(owlModel, createDIGReasoner(owlModel))
In the protege-core/build/ I've executed run_protege_server.sh  but arise
this issue: java.rmi.server.ExportException: port already in use: 1099.

I don't know what mean .



Thanks guys,
Best Regard

Matteo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20100921/c1795e7e/attachment.html>


More information about the protege-discussion mailing list