Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Export ontology from Protege server

Tania Tudorache tudorache at stanford.edu
Wed Jun 22 12:26:56 PDT 2011


Hi Jie,

I suppose you exported by going to the File menu -> Export and the 
selected OWL as a format.

I checked the files that you sent, and the exported one is incomplete. 
If you open it in a text editor, and scroll at the end of the file, you 
will see that the OWL file is cut at some point. This probably happened 
if the export process was terminated before the export actually 
finished. That is why you get errors when trying to load it into any of 
the Proteges.

If the export finished successfully, you will get pop-up window saying 
that export successful, and the path where it was created.

I just made a test with exporting the OPL copy we have on the the 
WebProtege server using the same method that you used, and it worked 
with no problem.

Tania


On 06/22/2011 08:34 AM, Jie Zheng wrote:
> Hi,
>
> I am working with WebProtege which both Protege server and Protege 
> rich client is Protege 3.4.6. I used Desktop protege to export the 
> ontology from the server using "Export to Format' XML. I got error 
> message when I open the exported ontology using both Protege 3.4.6 and 
> Protege 4.1.
>
> The error message got using Protege 3.4.6:
> "Errors found performing operation.
>
> 1. An error occurred at parsing the OWL ontology
>
>     http://purl.obolibrary.org/obo/opl.owl
>
>     at line 2045 and column 737.
>     Jena parse error message: XML document structures must start and 
> end within the same entity.
>     Exception class org.xml.sax.SAXParseException.  Message: XML 
> document structures must start and end within the same entity.
>
> See console and log for more details."
>
> The error message got using Protege 4.1:
> "Export ontology using Protege, export format as XML, when open using 
> Protege 4.1 got following error
>
> org.xml.sax.SAXParseException: XML document structures must start and 
> end within the same entity.
>
>
> Full Stack Trace
> ----------------------------------------------------------------------------------------- 
>
>
> org.coode.owlapi.rdfxml.parser.OWLRDFXMLParserSAXException: 
> org.xml.sax.SAXParseException: XML document structures must start and 
> end within the same entity.
>     at 
> org.coode.owlapi.rdfxml.parser.RDFXMLParser.parse(RDFXMLParser.java:129)
>     at 
> uk.ac.manchester.cs.owl.owlapi.ParsableOWLOntologyFactory.loadOWLOntology(ParsableOWLOntologyFactory.java:204)
>     at 
> uk.ac.manchester.cs.owl.owlapi.OWLOntologyManagerImpl.loadOntology(OWLOntologyManagerImpl.java:725)
>     at 
> uk.ac.manchester.cs.owl.owlapi.OWLOntologyManagerImpl.loadOntologyFromOntologyDocument(OWLOntologyManagerImpl.java:682)
>     at 
> org.protege.editor.owl.model.OWLModelManagerImpl.loadOntologyFromPhysicalURI(OWLModelManagerImpl.java:317)
>     at 
> org.protege.editor.owl.OWLEditorKit.handleLoadFrom(OWLEditorKit.java:180)
>     at 
> org.protege.editor.owl.OWLEditorKit.handleLoadRequest(OWLEditorKit.java:174)
>     at 
> org.protege.editor.core.ProtegeManager.openAndSetupEditorKit(ProtegeManager.java:157)
>     at 
> org.protege.editor.core.ProtegeWelcomeFrame$ProtegeWelcomePanel$2.actionPerformed(ProtegeWelcomeFrame.java:139)
>     at 
> org.protege.editor.core.ui.util.LinkLabel.activateLink(LinkLabel.java:102)
>     at 
> org.protege.editor.core.ui.util.LinkLabel.access$100(LinkLabel.java:30)
>     at 
> org.protege.editor.core.ui.util.LinkLabel$1.mouseReleased(LinkLabel.java:68)
>     at java.awt.Component.processMouseEvent(Unknown Source)
>     at javax.swing.JComponent.processMouseEvent(Unknown Source)
>     at java.awt.Component.processEvent(Unknown Source)
>     at java.awt.Container.processEvent(Unknown Source)
>     at java.awt.Component.dispatchEventImpl(Unknown Source)
>     at java.awt.Container.dispatchEventImpl(Unknown Source)
>     at java.awt.Component.dispatchEvent(Unknown Source)
>     at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
>     at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
>     at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
>     at java.awt.Container.dispatchEventImpl(Unknown Source)
>     at java.awt.Window.dispatchEventImpl(Unknown Source)
>     at java.awt.Component.dispatchEvent(Unknown Source)
>     at java.awt.EventQueue.dispatchEvent(Unknown Source)
>     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown 
> Source)
>     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown 
> Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.run(Unknown Source)
> Caused by: org.xml.sax.SAXParseException: XML document structures must 
> start and end within the same entity.
>     at 
> com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.endEntity(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.endEntity(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLEntityManager.endEntity(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.load(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.peekChar(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown 
> Source)
>     at 
> com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown 
> Source)
>     at javax.xml.parsers.SAXParser.parse(Unknown Source)
>     at 
> org.semanticweb.owlapi.rdf.syntax.RDFParser.parse(RDFParser.java:173)
>     at 
> org.coode.owlapi.rdfxml.parser.RDFXMLParser.parse(RDFXMLParser.java:119)
>     ... 31 more"
>
> I attached the exported owl file (opl_inferred_export.owl) and the 
> original file stored in the Protege server (opl_inferred_server.owl).
>
> Any idea of why it happen? Is it a bug of protege or did I do 
> something wrong?
>
> Thanks,
>
> Jie
>
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20110622/c21ab2f1/attachment.html>


More information about the protege-discussion mailing list