Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] slot facet changes not prophagating

Tom Cloyd tomcloydmsma at gmail.com
Mon Mar 26 05:55:45 PDT 2012


I'm working out my first ontology, and have run into a problem for which 
I can find no answer. I'm running ver. 3.4.8 on Kubuntu Linux 11.10.

I set up a slot with a cardinality of "required - at least 1", and a 
default value that was a string.

What I wanted was for an editable default value to appear in class 
instances using the slot.

PROBLEM #1: What I got was a NON-editable default value. That isn't 
acceptable, so I went back to edit the slot, removing the "required", 
and the default value.

PROBLEM #2: Returning to my class instance, the changes were not 
reflected, and the problem of the non-editable default value could not 
be fixed (at least by me). My instance was thus not unusable. I deleted it.

PROBLEM #3: It got worse: I created a new instance, only to discover 
that nothing had been changed. I still got a non-editable default value. 
Now it appears that my class has to be reconfigured. What if I have 1000 
instances, and deleting the slot was not an option?

Can anyone tell me what's going on, and how to fix/prevent these problems?

Thanks for any assistance you can offer!

Tom
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd / tc at tomcloyd.com / (435) 272-3332



More information about the protege-discussion mailing list