Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-discussion] Help : Protege 4 client server (Bleeding edge version)

Timothy Redmond tredmond at stanford.edu
Thu Nov 8 09:25:39 PST 2012


On 11/08/2012 01:42 AM, Dinbandhu Laxman Gauda wrote:

> 2) When I try to open .history(already uploaded file) file from server 
> I see the class hierarchy structure seems to be not correct. Some 
> classes are missing. Though individual looks file.

I thought that I would respond to this first as it looks like the most 
important item.  This is a minor bug in the client code that I will fix 
very soon.  When you load an ontology from the server, the import 
directives are being seen but not acted on.  So the ontology content of 
the ontology from the server is correct but is not being seen in the 
context of the imported ontologies.

You can verify this diagnosis by clicking on File->Loaded Ontology 
Sources in both copies of Protege.  In the copy of Protege where the 
ontology is loaded from the disk, you will see entries for all the 
imported ontologies.  In the copy of Protege where the ontology is 
loaded from the server, you will see that the imported ontologies are 
not loaded.  Unfortunately loading the imports after the fact does not 
help (I just checked).

Until I fix this, one thing that will work - and I think that this is a 
good way of interacting with the server  - is to save the copy of the 
ontology that you uploaded from the server.  When this copy is saved, 
Protege will also save some information about the server connection (see 
the .owlserver directory).  If you come back and open this saved copy of 
the ontology, Protege will know that the ontology corresponds to a 
server ontology and all the server related capabilities will be present, 
including auto-update.

> Hi,
>
> I am now able to deploy , start and connect Protege4 server.  Thanks 
> for all your help and support.
>

I am very happy to hear that.  What was the last issue that you fixed to 
get it to work?  Was it the java version?  Do you have any advice for me 
to make this easier in the future?

> I have couple of more issues
>
> 1) After uploading owl file to server, it saves it as a .history file. 
> This file seems to be a flat file. In the final release, will this 
> file have the same extension.?
>

It is a flat file.  It is a new type of format, invented by Matthew, 
that represents change sets between ontology versions in a very 
efficient manner.  Thus this file contains a list of the changes made to 
the ontology from revision 0 to revision 1, from revision  1 to revision 
2, etc.  This file format can be read in very rapidly allowing the 
server to provide a list of the changes between any two revisions of an 
ontology on demand.  The format is a hand crafted binary serialization 
of the change sets.  Matthew has found that the entire SNOMED ontology 
can be loaded into the OWL api from this type of file in under two seconds.

The extension may change in a future release.  Matthew has a better 
version of this file format and when his code is released we plan to 
move to that format.  If this happens, I plan on making a converter 
between the two formats so that no information is lost.  It is possible 
that if this happens, we will change the extension.

This is a very critical file and one of the improvements that I am 
planning is to have is to add more robustness mechanisms to protect this 
file.

-Timothy



> 2) When I try to open .history(already uploaded file) file from server 
> I see the class hierarchy structure seems to be not correct. Some 
> classes are missing. Though individual looks file.
>
> Attached is a screen shot with more details
>
> Owl file :
>
>
> From Server:
>
>
> Thanks
>
> -Dinu
>
> -----Original Message-----
> From: protege-discussion-bounces at lists.stanford.edu 
> [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of 
> protege-discussion-request at lists.stanford.edu
> Sent: Wednesday, November 07, 2012 1:55 AM
> To: protege-discussion at lists.stanford.edu
> Subject: protege-discussion Digest, Vol 76, Issue 7
>
> Send protege-discussion mailing list submissions to
>
> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> To subscribe or unsubscribe via the World Wide Web, visit
>
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> or, via email, send a message with subject or body 'help' to
>
> protege-discussion-request at lists.stanford.edu 
> <mailto:protege-discussion-request at lists.stanford.edu>
>
> You can reach the person managing the list at
>
> protege-discussion-owner at lists.stanford.edu 
> <mailto:protege-discussion-owner at lists.stanford.edu>
>
> When replying, please edit your Subject line so it is more specific 
> than "Re: Contents of protege-discussion digest..."
>
> Today's Topics:
>
>    1. Re: Help : Protege 4 client server (Bleeding edge version)
>
>       (Timothy Redmond)
>
> ----------------------------------------------------------------------
>
> Message: 1
>
> Date: Tue, 06 Nov 2012 12:24:51 -0800
>
> From: Timothy Redmond <tredmond at stanford.edu 
> <mailto:tredmond at stanford.edu>>
>
> To: protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> Subject: Re: [protege-discussion] Help : Protege 4 client server
>
>                 (Bleeding edge version)
>
> Message-ID: <50997213.5090404 at stanford.edu 
> <mailto:50997213.5090404 at stanford.edu>>
>
> Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"
>
> I set the logging level to debug for the service starter (do svn 
> update).  This seems like a good default because the logging 
> information is not that voluminous and might have just the information 
> that we need.
>
> -Timothy
>
> On 11/6/12 11:19 AM, Timothy Redmond wrote:
>
> > On 11/5/12 11:35 PM, Dinbandhu Laxman Gauda wrote:
>
> >> Hi,
>
> >>
>
> >> Thanks for looking into this Prot?g? 4 item and for a quick reply.  
> Below is a log from commons-daemon log file and ant log which gives 
> some more information on the error. Attached is ant log as well for 
> more details..
>
> >>
>
> >> Couple of things I would like to know
>
> >> 1) I do not see any executales or ant targets to run client.
>
> >
>
> > The main way to run the client is to
>
> >
>
> >  1. download the latest Protege 4.2 distribution [2]  2. add the two
>
> > files from the client installation page to the plugins
>
> >     directory of the Protege 4.2 distribution location (usually
>
> >     something like C:\Program Files\Protege_4.2_beta by default).
>
> >
>
> > Then you will be able to run the client as shown in the first video
>
> > [3].  This should have been there before but our documentation is
>
> > still getting worked out.
>
> >
>
> > We also have some command-line capabilities that allow you to use the
>
> > server with tools other than Protege but I haven't written the windows
>
> > scripts yet.
>
> >
>
> >> 2) I have created plugins folder under C:\Program Files\Protege OWL 
> Server\, just want to know this is a correct place.
>
> >
>
> > Don't put anything there yet.  As of now we don't have any Protege OWL
>
> > server plugins though the support is all there already.
>
> >> 3) even I tried to start server using this command line statement 
> "OWLDocService //ES//OWLServer"  , but I do not see server in running 
> mode in both services or in taskmanager/services, both are showing 
> Stopped.
>
> >
>
> > Yes you are gathering all the right data and this is very useful. This
>
> > error message - "Failed creating java" - is frustratingly
>
> > uninformative.  Not too long ago I spent a whole weekend banging my
>
> > head against a very similar error message only to realize that I was
>
> > using a 32-bit executable and an incompatible memory setting.  (This
>
> > is why I thought that it might be a memory problem before).
>
> >
>
> > At the moment, I only have one theory and one workaround which I think
>
> > will work.  I am wondering if you are using the java that came with
>
> > Windows or if you installed Oracle's java.  I know from past messages
>
> > that the java that comes with windows can cause problems.
>
> >
>
> > If you are using Oracle's java then, hopefully today, I will add a
>
> > .bat run script that I am pretty sure will work.  This approach has
>
> > the disadvantage that you will have to start the server manually on
>
> > each reboot but it should remove some of the variables that are giving
>
> > us trouble.  I will also keep thinking about what else might be wrong.
>
> > Finally I will look into seeing if we can run a public server over
>
> > here which would allow you to try out the client.
>
> >
>
> > Thank you for the help debugging and apologies for the wrinkles that
>
> > we have not yet worked out.
>
> >
>
> > -Timothy
>
> >
>
> > [1]http://protegewiki.stanford.edu/wiki/Protege4ClientServer#Installat
>
> > ion_details [2]http://protege.stanford.edu/download/download.html
>
> > [3]http://protegewiki.stanford.edu/wiki/Protege4ClientServer#Videoss
>
> >> Commons-Daemon log:
>
> >> [2012-11-06 12:44:26] [info] Commons Daemon procrun (1.0.10.0
>
> >> 32-bit) started
>
> >> [2012-11-06 12:44:26] [info] Running 'OWLServer' Service...
>
> >> [2012-11-06 12:44:26] [info] Starting service...
>
> >> [2012-11-06 12:44:26] [error] Failed creating java
>
> >> [2012-11-06 12:44:26] [error] ServiceStart returned 1
>
> >> [2012-11-06 12:44:26] [info] Run service finished.
>
> >> [2012-11-06 12:44:26] [info] Commons Daemon procrun finished
>
> >> [2012-11-06 12:55:53] [info] Commons Daemon procrun (1.0.10.0
>
> >> 32-bit) started
>
> >> [2012-11-06 12:55:53] [info] Service OWLServer name OWLServer
>
> >> [2012-11-06 12:55:53] [info] Service 'OWLServer' installed
>
> >> [2012-11-06 12:55:53] [info] Commons Daemon procrun finished
>
> >> [2012-11-06 12:55:53] [info] Commons Daemon procrun (1.0.10.0
>
> >> 32-bit) started
>
> >> [2012-11-06 12:55:53] [info] Starting service 'OWLServer' ...
>
> >> [2012-11-06 12:55:53] [info] Commons Daemon procrun (1.0.10.0
>
> >> 32-bit) started
>
> >> [2012-11-06 12:55:53] [info] Running 'OWLServer' Service...
>
> >> [2012-11-06 12:55:53] [info] Starting service...
>
> >> [2012-11-06 12:55:53] [error] Failed creating java
>
> >> [2012-11-06 12:55:53] [error] ServiceStart returned 1
>
> >> [2012-11-06 12:55:53] [info] Run service finished.
>
> >> [2012-11-06 12:55:53] [info] Commons Daemon procrun finished
>
> >> [2012-11-06 12:55:54] [error] Failed to start 'OWLServer' service
>
> >> [2012-11-06 12:55:54] [error] The data area passed to a system call 
> is too small.
>
> >> [2012-11-06 12:55:54] [info] Start service finished.
>
> >> [2012-11-06 12:55:54] [error] Commons Daemon procrun failed with exit
>
> >> value: 5 (Failed to start service)
>
> >> [2012-11-06 12:55:55] [error] The data area passed to a system call 
> is too small.
>
> >>
>
> >> Ant Log:
>
> >> deploy.windows:
>
> >>       [echo] Deploying windows Protege OWL Server
>
> >>       [echo] Will run as protege : C:/Program Files/Protege OWL 
> Server/logs
>
> >>       [exec] Current OS is Windows 7
>
> >>       [exec] Executing 'C:\Program Files\Protege OWL 
> Server\bin\OWLDocService.exe' with arguments:
>
> >>       [exec] '//IS//OWLServer'
>
> >>       [exec] '--Install=C:\Program Files\Protege OWL 
> Server\bin\OWLDocService.exe'
>
> >>       [exec] '--Jvm=auto'
>
> >>       [exec] '--Description=Protege-OWL-Document-Service'
>
> >>       [exec] '--DisplayName=OWLServer'
>
> >>       [exec] '--LogPath=C:/Program Files/Protege OWL Server/logs'
>
> >>       [exec] '--StdOutput=auto'
>
> >>       [exec] '--StdError=auto'
>
> >>       [exec] '--Startup=auto'
>
> >>       [exec] 
> '--Classpath=bin/winsvc.jar;lib/felix.jar;lib/ProtegeLauncher.jar'
>
> >>       [exec] '--JvmMx=700'
>
> >>       [exec] '++JvmOptions=-DentityExpansionLimit=100000000'
>
> >>       [exec] '++JvmOptions=-Dfile.encoding=UTF-8'
>
> >>       [exec] '++JvmOptions=-Djava.rmi.server.hostname=dinu'
>
> >>       [exec] 
> '++JvmOptions=-Dorg.protege.owl.server.configuration=metaproject.owl'
>
> >>       [exec] 
> '++JvmOptions=-Djava.util.logging.config.file=logging.properties'
>
> >>       [exec] '--StartPath=C:\Program Files\Protege OWL Server'
>
> >>       [exec] '--StartMode=jvm'
>
> >>       [exec] 
> '--StartClass=org.protege.owl.server.deploy.windows.WindowsOWLServer'
>
> >>       [exec] '--StartParams=start'
>
> >>       [exec] '--StopPath=C:\Program Files\Protege OWL Server'
>
> >>       [exec] '--StopMode=jvm'
>
> >>       [exec] 
> '--StopClass=org.protege.owl.server.deploy.windows.WindowsOWLServer'
>
> >>       [exec] '--StopParams=stop'
>
> >>       [exec]
>
> >>       [exec] The ' characters around the executable and arguments are
>
> >>       [exec] not part of the command.
>
> >>       [echo] prefix C:\Program Files\Protege OWL 
> Server\bin\OWLDocService.exe
>
> >>       [exec] Current OS is Windows 7
>
> >>       [exec] Executing 'C:\Program Files\Protege OWL 
> Server\bin\OWLDocService.exe' with arguments:
>
> >>       [exec] '//ES//OWLServer'
>
> >>       [exec]
>
> >>       [exec] The ' characters around the executable and arguments are
>
> >>       [exec] not part of the command.
>
> >>        [ant] Exiting 
> D:\work\workspace\protegeserver4\org.protege.owl.server.deploy\build.xml.
>
> >>
>
> >> BUILD FAILED
>
> >> D:\work\workspace\protegeserver4\build.xml:35: The following error 
> occurred while executing this line:
>
> >> 
> D:\work\workspace\protegeserver4\org.protege.owl.server.deploy\build.xml:339: 
> exec returned: 5
>
> >>           at 
> org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:646)
>
> >>           at 
> org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:672)
>
> >>           at 
> org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:498)
>
> >>           at 
> org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
>
> >>           at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown 
> Source)
>
> >>           at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> >>           at java.lang.reflect.Method.invoke(Method.java:597)
>
> >>
>
> >>
>
> >> Thanks
>
> >> -Dinu
>
> >>
>
> >> -----Original Message-----
>
> >> From:protege-discussion-bounces at lists.stanford.edu
>
> >> [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf
>
> >> Ofprotege-discussion-request at lists.stanford.edu 
> <mailto:Ofprotege-discussion-request at lists.stanford.edu>
>
> >> Sent: Tuesday, November 06, 2012 5:10 AM
>
> >> To:protege-discussion at lists.stanford.edu
>
> >> Subject: protege-discussion Digest, Vol 76, Issue 4
>
> >>
>
> >> Send protege-discussion mailing list submissions to
>
> >> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >>
>
> >> To subscribe or unsubscribe via the World Wide Web, visit
>
> >> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >> or, via email, send a message with subject or body 'help' to
>
> >> protege-discussion-request at lists.stanford.edu 
> <mailto:protege-discussion-request at lists.stanford.edu>
>
> >>
>
> >> You can reach the person managing the list at
>
> >> protege-discussion-owner at lists.stanford.edu 
> <mailto:protege-discussion-owner at lists.stanford.edu>
>
> >>
>
> >> When replying, please edit your Subject line so it is more specific 
> than "Re: Contents of protege-discussion digest..."
>
> >>
>
> >>
>
> >> Today's Topics:
>
> >>
>
> >>     1. Re: Help : Protege 4 client server (Bleeding edge version)
>
> >>        (Timothy Redmond)
>
> >>
>
> >>
>
> >> ---------------------------------------------------------------------
>
> >> -
>
> >>
>
> >> Message: 1
>
> >> Date: Mon, 05 Nov 2012 15:39:22 -0800
>
> >> From: Timothy Redmond<tredmond at stanford.edu 
> <mailto:tredmond at stanford.edu>>
>
> >> To:protege-discussion at lists.stanford.edu
>
> >> Subject: Re: [protege-discussion] Help : Protege 4 client server
>
> >>           (Bleeding edge version)
>
> >> Message-ID:<50984E2A.9020408 at stanford.edu 
> <mailto:50984E2A.9020408 at stanford.edu>>
>
> >> Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"
>
> >>
>
> >>
>
> >> I am running 32-bit windows in a virtualbox and have replicated a
>
> >> problem with your symptoms. The windows error messages are aweful!  I
>
> >> will have to see if there is anything that I can do about this as I 
> refine this process.
>
> >>
>
> >> I also realized that there is an important step that is not yet 
> documented - to be able to interact with the server you need to 
> install the Protege client jars.  When the Protege OWL server is 
> released, these will be included in the Protege distribution.  In the 
> meantime, I have attached two jar files that you can put in the 
> Protege plugins directory.
>
> >>
>
> >> First do an svn update on the server directory - I have fixed a 
> couple of typos.  Second, I have determined that if the server has 
> been deployed then if the deploy target is called it will fail with 
> exactly the "exec returned: 8" error message.  The solution is to run 
> "ant undeploy" to clean up and then run "ant deploy" to put the 
> service back.
>
> >>
>
> >> I hope that this fixes the problem for you but if it doesn't I will 
> soon write a .bat script that will let you manually start running the 
> server. This script would not resume running on a reboot but it will 
> allow you to proceed even if my scripts to configure the apache daemon 
> don't work.
>
> >>
>
> >> You can monitor if the OWL server has been installed by looking at 
> the Services application.  You can find this by going to the "Start" 
> menu and searching for "services".  When you run this program it will 
> show all the installed services and the OWL Server will show up as 
> "OWLServer".  This is shown in the diagram that I have included below.
>
> >>
>
> >> -Timothy.
>
> >>
>
> >>
>
> >>
>
> >>
>
> >>
>
> >>
>
> >> On 11/1/12 12:27 PM, Timothy Redmond wrote:
>
> >>> I am sorry for the delay on looking at this.  I am trying to get my
>
> >>> hands on a 32-bit windows image for testing.  But I did have one
>
> >>> thought.  Make sure that the memory.mb setting in the
>
> >>> local.properties file is less than 2048 because a 32-bit windows
>
> >>> process can't handle more than 2 gig of memory.  When I was testing
>
> >>> this before I noticed that some of the errors under windows are a 
> bit obscure.
>
> >>>
>
> >>> -Timothy
>
> >>>
>
> >>>
>
> >>> On 10/31/12 5:04 AM, Dinbandhu Laxman Gauda wrote:
>
> >>>> The below issue  is resolved by fixing this line in build.xml file.
>
> >>>>
>
> >>>>
>
> >>>> <target name="install.windows32.files" depends="jar, 
> install.noarch.files" if="is.windows32">
>
> >>>> <!--copy file="${service64.src}" tofile="${service}"/>   -->
>
> >>>>     <copy file="${service32.src}"  tofile="${service}"/>
>
> >>>>     </target>
>
> >>>>
>
> >>>> But I am seeing other issues like..  Attached is a ant log file..
>
> >>>>
>
> >>>> BUILD FAILED
>
> >>>> D:\work\workspace\protege-server-4\build.xml:35: The following 
> error occurred while executing this line:
>
> >>>> 
> D:\work\workspace\protege-server-4\org.protege.owl.server.deploy\build.xml:310: 
> exec returned: 8
>
> >>>>     at 
> org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:646)
>
> >>>>     at 
> org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:672)
>
> >>>>     at 
> org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:498)
>
> >>>>     at 
> org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
>
> >>>>     at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
>
> >>>>     at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> >>>>     at java.lang.reflect.Method.invoke(Method.java:597)
>
> >>>>     at 
> org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
>
> >>>>     at org.apache.tools.ant.Task.perform(Task.java:348)
>
> >>>>     at org.apache.tools.ant.Target.execute(Target.java:392)
>
> >>>>     at org.apache.tools.ant.Target.performTasks(Target.java:413)
>
> >>>>     at 
> org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
>
> >>>>     at 
> org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
>
> >>>>     at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
>
> >>>>     at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:442)
>
> >>>>     at 
> org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
>
> >>>>     at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
>
> >>>>     at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> >>>>     at java.lang.reflect.Method.invoke(Method.java:597)
>
> >>>>     at 
> org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
>
> >>>>     at org.apache.tools.ant.Task.perform(Task.java:348)
>
> >>>>     at org.apache.tools.ant.Target.execute(Target.java:392)
>
> >>>>     at org.apache.tools.ant.Target.performTasks(Target.java:413)
>
> >>>>     at 
> org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
>
> >>>>     at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
>
> >>>>     at 
> org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
>
> >>>>     at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
>
> >>>>     at org.apache.tools.ant.Main.runBuild(Main.java:811)
>
> >>>>     at org.apache.tools.ant.Main.startAnt(Main.java:217)
>
> >>>>     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
>
> >>>>     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
>
> >>>>
>
> >>>>
>
> >>>>
>
> >>>> -----Original Message-----
>
> >>>> From: Dinbandhu Laxman Gauda
>
> >>>> Sent: Wednesday, October 31, 2012 4:38 PM
>
> >>>> To: 'protege-discussion at lists.stanford.edu'
>
> >>>> Subject: RE: [protege-discussion] Help : Protege 4 client server
>
> >>>> (Bleeding edge version)
>
> >>>>
>
> >>>> Hi,
>
> >>>>
>
> >>>> I am not able to deploy Prot?g? 4 server  on Windows 7 (32 bit) 
> even though exe is installed for x32 bit.
>
> >>>>
>
> >>>> Similar issue is with clean.full as well
>
> >>>>
>
> >>>> Attached is a log from ant build.
>
> >>>>
>
> >>>> Thanks
>
> >>>> -Dinu
>
> >>>>
>
> >>>> -----Original Message-----
>
> >>>> From:protege-discussion-bounces at lists.stanford.edu
>
> >>>> [mailto:protege-discussion-bounces at lists.stanford.edu] On Behalf Of
>
> >>>> Timothy Redmond
>
> >>>> Sent: Wednesday, 31 October, 2012 12:52
>
> >>>> To:protege-discussion at lists.stanford.edu
>
> >>>> Subject: Re: [protege-discussion] Help : Protege 4 client server
>
> >>>> (Bleeding edge version)
>
> >>>>
>
> >>>> On 10/30/2012 10:08 PM, Dinbandhu Laxman Gauda wrote:
>
> >>>>> Hi Timothy,
>
> >>>>>
>
> >>>>> Attached is a log text file.  I looked at
>
> >>>>> org.protege.owl.server.jar file and looks like
>
> >>>>> SetMetaprojectDataDir.class file is missing. I infact .java file
>
> >>>>> is also missing from
>
> >>>>> org.protege.owl.server\src\main\java\org\protege\owl\server\comman
>
> >>>>> d
>
> >>>>> folder
>
> >>>>>
>
> >>>>> Thanks
>
> >>>>> -Dinu
>
> >>>>>
>
> >>>> Thanks very much for the help.  This problem was completely my
>
> >>>> mistake - actually I made several mistakes to make this happen.  It
>
> >>>> has been broken for a bit and I didn't notice.  If you update and
>
> >>>> try again I think that it will work.  (I just ran the installer in
>
> >>>> both linux and
>
> >>>> windows.)
>
> >>>>
>
> >>>> One of the things that I changed to fix this was to change the 
> ant clean target and add a clean.full target.  The clean target now 
> just cleans up the built artifacts in the checked out directories.  
> The clean.full target will also clean up the Protege OWL server files 
> that have been installed in the system directories.
>
> >>>>
>
> >>>> You have also helped me see that I can simplify this process when 
> the server is ready for release.  The current version involves two 
> projects (the server project and the server deployer project) that get 
> built.  If anything goes wrong in either one then the build fails.  
> But really all we need to distribute is the deployer project together 
> with a built copy of the server.
>
> >>>>
>
> >>>> -Timothy
>
> >>>>
>
> >>>>
>
> >>>> _______________________________________________
>
> >>>> protege-discussion mailing list
>
> >>>> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >>>> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >>>>
>
> >>>> Instructions for
>
> >>>> unsubscribing:http://protege.stanford.edu/doc/faq.html#01a.03
>
> >>>>
>
> >>>> **************** CAUTION - Disclaimer ***************** This e-mail
>
> >>>> contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely
>
> >>>> for the use of the addressee(s). If you are not the intended
>
> >>>> recipient, please notify the sender by e-mail and delete the 
> original message.
>
> >>>> Further, you are not to copy, disclose, or distribute this e-mail
>
> >>>> or its contents to any other person and any such actions are 
> unlawful.
>
> >>>> This e-mail may contain viruses. Infosys has taken every reasonable
>
> >>>> precaution to minimize this risk, but is not liable for any damage
>
> >>>> you may sustain as a result of any virus in this e-mail. You should
>
> >>>> carry out your own virus checks before opening the e-mail or
>
> >>>> attachment. Infosys reserves the right to monitor and review the
>
> >>>> content of all messages sent to or from this e-mail address. 
> Messages sent to or from this e-mail address may be stored on the 
> Infosys e-mail system.
>
> >>>> ***INFOSYS******** End of Disclaimer ********INFOSYS***
>
> >>>>
>
> >>>>
>
> >>>> _______________________________________________
>
> >>>> protege-discussion mailing list
>
> >>>> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >>>> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >>>>
>
> >>>> Instructions for
>
> >>>> unsubscribing:http://protege.stanford.edu/doc/faq.html#01a.03
>
> >>>
>
> >>> _______________________________________________
>
> >>> protege-discussion mailing list
>
> >>> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >>> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >>>
>
> >>> Instructions for unsubscribing:
>
> >>> http://protege.stanford.edu/doc/faq.html#01a.03
>
> >> -------------- next part -------------- An HTML attachment was
>
> >> scrubbed...
>
> >> 
> URL:<http://mailman.stanford.edu/pipermail/protege-discussion/attachm 
> <URL:%3chttp://mailman.stanford.edu/pipermail/protege-discussion/attachm>
>
> >> ents/20121105/40305f8e/attachment.html>
>
> >> -------------- next part -------------- A non-text attachment was
>
> >> scrubbed...
>
> >> Name: eabajdbe.png
>
> >> Type: image/png
>
> >> Size: 281213 bytes
>
> >> Desc: not available
>
> >> 
> URL:<http://mailman.stanford.edu/pipermail/protege-discussion/attachm 
> <URL:%3chttp://mailman.stanford.edu/pipermail/protege-discussion/attachm>
>
> >> ents/20121105/40305f8e/attachment.png>
>
> >> -------------- next part -------------- A non-text attachment was
>
> >> scrubbed...
>
> >> Name: org.protege.owl.server.jar
>
> >> Type: application/java-archive
>
> >> Size: 2036748 bytes
>
> >> Desc: not available
>
> >> 
> URL:<http://mailman.stanford.edu/pipermail/protege-discussion/attachm 
> <URL:%3chttp://mailman.stanford.edu/pipermail/protege-discussion/attachm>
>
> >> ents/20121105/40305f8e/attachment.jar>
>
> >> -------------- next part -------------- A non-text attachment was
>
> >> scrubbed...
>
> >> Name: org.protege.editor.owl.client.jar
>
> >> Type: application/java-archive
>
> >> Size: 60218 bytes
>
> >> Desc: not available
>
> >> 
> URL:<http://mailman.stanford.edu/pipermail/protege-discussion/attachm 
> <URL:%3chttp://mailman.stanford.edu/pipermail/protege-discussion/attachm>
>
> >> ents/20121105/40305f8e/attachment-0001.jar>
>
> >>
>
> >> ------------------------------
>
> >>
>
> >> _______________________________________________
>
> >> protege-discussion mailing list
>
> >> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >>
>
> >>
>
> >> End of protege-discussion Digest, Vol 76, Issue 4
>
> >> *************************************************
>
> >>
>
> >>
>
> >> _______________________________________________
>
> >> protege-discussion mailing list
>
> >> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> >> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >>
>
> >> Instructions for
>
> >> unsubscribing:http://protege.stanford.edu/doc/faq.html#01a.03
>
> >
>
> >
>
> >
>
> > _______________________________________________
>
> > protege-discussion mailing list
>
> > protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> > https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> >
>
> > Instructions for unsubscribing:
>
> > http://protege.stanford.edu/doc/faq.html#01a.03
>
> -------------- next part --------------
>
> An HTML attachment was scrubbed...
>
> URL: 
> <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20121106/0f23de14/attachment.html>
>
> -------------- next part --------------
>
> A non-text attachment was scrubbed...
>
> Name: Logging.png
>
> Type: image/png
>
> Size: 510615 bytes
>
> Desc: not available
>
> URL: 
> <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20121106/0f23de14/attachment.png>
>
> ------------------------------
>
> _______________________________________________
>
> protege-discussion mailing list
>
> protege-discussion at lists.stanford.edu 
> <mailto:protege-discussion at lists.stanford.edu>
>
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> End of protege-discussion Digest, Vol 76, Issue 7
>
> *************************************************
>
>
>
> _______________________________________________
> protege-discussion mailing list
> protege-discussion at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-discussion
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-discussion/attachments/20121108/0ce46ff7/attachment-0001.html>


More information about the protege-discussion mailing list