Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] WARNING: java.lang.NoClassDefFoundError: edu/stanford/smi/protegex/owl/model/OWL

Andres Betancourt listaprotege at gmail.com
Tue Apr 3 12:18:50 PDT 2007


Hi all,

I'm currently working on a plugin for Protégé and I'm trying to obtain the
OWLModel like this:

this.project = ProjectManager.getProjectManager().getCurrentProject();
//Line 49
this.owlModel = (OWLModel) project.getKnowledgeBase(); //Line 50

this compile whit no problem, but when I open my plugin I get this warning
and my plugin doesn't load:

Protege Wizards v1.0 beta build 14
Loaded OWL wizards library
WARNING: java.lang.NoClassDefFoundError:
edu/stanford/smi/protegex/owl/model/OWL
Model
        at cmap.gui.ConceptMap.<init>(ConceptMap.java :50)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        ...

I don't understand why I get this error since the directory of this class is
in my classpath (protege-owl.jar). My hole classpath is:

CLASSPATH=C:\Program Files\Protege_3.2.1\plugins;C:\Program
Files\Java\jre1.6.0\lib\ext;C:\Program
Files\Java\jdk1.6.0\jre\lib\ext;C:\Program
Files\Protege_3.2.1\protege.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\antlr-
2.7.5;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\arq.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\commons-
lang-2.0.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\commons-
logging.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\concurrent.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\edtftpj-1.5.2.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\ekitspell.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\icu4j_3_4.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\iri.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\jcalendar.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\jena.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\json.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\junit.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\kazuki.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\log4j-
1.2.12.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\owlsyntax.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\protege-owl.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\stax-
api-1.0.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\swrl-
jess-bridge.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\wstx-asl-2.8.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\xercesImpl.jar;C:\Program
Files\Protege_3.2.1\plugins\edu.stanford.smi.protegex.owl\xml- apis.jar;

If anybody know why i get this error please reply me, I have search for this
a lot.

thank you in advance.

Andres.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-owl/attachments/20070403/aa191488/attachment.html>


More information about the protege-owl mailing list