Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] plugin loading problem

Thomas Russ tar at ISI.EDU
Mon Apr 23 12:01:19 PDT 2007

On Apr 23, 2007, at 9:56 AM, Andres Betancourt wrote:

> Hi all,
> I am developing a plugin for Protégé and compiling with java 1.6  
> with no problem, but when i install Protégé 3.2 with the installer  
> that includes the java VM
> my plugin doesn`t load. then i compiled my code with java 1.5.0  
> wich i understand is the version included in this installer, but  
> the problem persist and this warning appear:
> CONFIG: Loaded plugin cmap - cmap
> WARNING: java.lang.UnsupportedClassVersionError: Bad version number  
> in .class file -- PluginUtilities.isLoadableClass()
> does anybody knows whi i get this error

This should only happen if you use a Java 1.6 class file in Java 1.5  
(or earlier).  My guess is that you have somehow managed to not get  
the Java 1.5 version installed -- either because the class was not  
recompiled (possible if your development environment or java compiler  
noticed that the source file was older than the class file) or  
because the wrong class version was picked when creating the jar file  
or copying it to the plugins directory.

I would clear out all of the compiled Java files and your jar file  
and just try it over.

> my intencion is that anybody who intall Protégé 3.2 with included  
> VM or choosing java already installed >= 1.5.0 can load my plugin

I would think that you would then need to either compile using Java  
1.5 or else specify the output target language to be 1.5 using the  
Java 1.6 compiler.  The IMHO safer method is to use Java 1.5 for the  

More information about the protege-owl mailing list