Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] problem with loading protege plugins

Thomas Russ tar at ISI.EDU
Thu Apr 26 08:54:26 PDT 2007


On Apr 26, 2007, at 4:07 AM, Miroslav Hořejší wrote:

> Hi,
> I have a problem with loading protege plugins. I'm using Netbeans  
> 5.5, I wonna use JenaOWLModel, so I imported protege-owl.jar from  
> directory, where I installed protege 3.2.1, but when I ran my  
> project, it threw me this exception:
> Exception in thread "main" java.lang.NoClassDefFoundError: edu/ 
> stanford/smi/protege/model/KnowledgeBase
>         at java.lang.ClassLoader.defineClass1(Native Method)
> And in my source code is only this: JenaOWLModel owlModel =  
> ProtegeOWL.createJenaOWLModel();
> Could anybody help me?? I don't know, what should I do to run my  
> project

You need to import more of the jars.

You will also need the normal protege.jar

It is unfortunately a bit tricky to find the instructions in the on- 
line documentation, but the information is covered at <http:// 
protege.cim3.net/cgi-bin/wiki.pl?CompileProtegeSourcesInIDE>, even  
though you don't need to compile the Protege sources.

The short answer is that you need the following jar files:
   1)  All jar files from the Protege installation directory
   2)  All jar files from the plugins/edu.stanford.smi.protegex.owl  
directory


> _______________________________________________
> protege-owl mailing list
> protege-owl at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/ 
> faq.html#01a.03




More information about the protege-owl mailing list