Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] SWRL Racer problem

Samson Tu swt at stanford.edu
Wed Aug 29 12:50:21 PDT 2007


Hi Trina,

Martin is on vacation now.

The error message appears to say that there is some incompatibility 
between RAcer and the SWRL query mechanism that Martin implemented. If 
you don't use SWRL query, can you unimport query.owl and see whether it 
works?

Samson

Trina wrote:
> Hi Martin and everyone,
> 
> In a previous post I reported a bug with Racer, SWRLtab and computing inferred
> types. Inferring over the ontology is fine using 'compute inferred types' until
> I initiate the SWRLtab. Then I get error messages like:
> 
> DIG Reasoner Error: Undefined individual name|query:comumnNames|in ABox |
> http://dl.kr.org/dig/kb-58950|[ID: query:columnNames]
> when computing inferred types through Racer.
> 
> I was wondering if you had heard any feedback from this bug report? It has
> become a major problem as I can't continue with my research until I can resolve
> why this is occurring. I though it might have been an anomalous glitch in  414
> but I have just tested it with the latest version (430) and the same thing keeps
> occurring. I have used 3 different machines, I have downloaded RacerPro and Jess
> again and did a clean install for both but still the errors happen.
> 
> I can send a screenshot showing the problem. One such incident happened after
> opeing a new project and creating 2 classes (no restrictions, instances, etc),
> setting up the SWRLtab and activating it. At this stage computing inferred types
> works fine, however, anything after this ends in the error message (the screen
> shot shows a simple rule is written but not yet sent to the Jess engine). I
> tried it using the 'collabborativePizza' ontology supplied with version 430,
> after deleting the classes that made it inconsistent I set up the swrlTab and
> imported the SWRL ontologies...the error occurred as soon as I tried to compute
> inferred types...
> 
> I have an old version on one of the machines (399) and the errors do not occur??
> 
> Any suggestions or answers would be extremely appreciated!
> 
> 
> 
> _______________________________________________
> protege-owl mailing list
> protege-owl at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
> 
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03 
> 


-- 
Samson Tu                    email: swt at stanford.edu
Senior Research Scientist    web: www.stanford.edu/~swt/
Stanford Medical Informatics phone: 1-650-725-3391
Stanford University          fax: 1-650-725-7944




More information about the protege-owl mailing list