Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Pellet gives strange, wrong error with Booleans

Thomas Russ tar at ISI.EDU
Thu Aug 30 12:15:17 PDT 2007


On Aug 30, 2007, at 11:19 AM, Stephen Larson wrote:

> Bijan,
>
>    Sorry for not using the appropriate channels before.  I have  
> included other lists on this because I think that it is important  
> to clear this up.
>
>    I'm sending you the simplest example of this problem that I can  
> find.  It doesn't seem to happen with a single simple case of the  
> presence of a boolean.  The behavior appears to be more complex  
> than that.  But it is the case that the problem exists, I've sent  
> you an example ontology that exhibits it, and it can be reversed by  
> commenting out the booleans.  It is reproducible if you use the  
> tools that I have described.
>
>    I understand if you are frustrated with the DIG interface.  But,  
> it seems like you are implying that Pellet doesn't really support  
> the interface.

The issue isn't with Pellet.  It was an encoding problem with  
Protege's DIG interface.

I recently reported this and Tania Tudorache indicated on Aug. 28  
that a fix for the problem was going in.  Look for the messages on  
the Protege-OWL mailing list with the subject
    "Problem with DIG rendering of boolean-valued properties"

Synopsis for non-subscribers:  Protege was mapping boolean datatypes  
to int for DIG, but not translating the "true" and "false" values  
into integers.  Protege will now map true => 1 and false => 0 as  
well, which should solve the problem by transforming boolean-valued  
datatype properties into limited integer-valued ones.

>
>    I'm just a naive user here with limited resources.  I'd like to  
> use Pellet to check out my ontology in Protege 3.3.1 without having  
> to acquire a 'toolchain' in order to do it.  The pellet website  
> says it supports DIG: http://pellet.owldl.com/faq/protege/.  But it  
> seems like maybe it doesn't really.  So it seems like the DIG  
> interface is really just a distraction and shouldn't be included in  
> code intended for naive end-users.  Maybe some agreement between  
> the Pellet and the Protege people to stop supporting the DIG  
> interface would be the best route to avoid naive users like me from  
> falling into these kinds of traps, getting misleading error  
> statements and thus being unable to fix their ontologies so that  
> Pellet can reason with them.  I think that would be best for the  
> community.
>
> --Stephen
>
> On 8/30/07, Bijan Parsia < bparsia at cs.man.ac.uk> wrote: First,  
> there is a Pellet support mailing list:
>         <http://lists.owldl.com/mailman/listinfo/pellet-users/ >
>
> I really prefer these sorts of question to be directed there or to
> public-owl-dev at w3.org, that way more people benefit and more people
> can pitch in.
>
> Second, DIG is just unreliable, esp. with datatypes. I tried your
> ontology in Protege4alpha (afaict, you are using Protege 3.x, which
> really makes the report "latest Protege" meaningless). It works with
> both FaCT++ and Pellet in Protege4. It works in OWLSight.
>
> (You do well to try several different avenues to avoid getting stuck
> in these sorts of tool effects. These days, there are plenty of ways
> to gather data about what part of the toolchain is causing trouble.)
>
> So, as I cannot reproduce your problem, I don't see what it is ;) A
> tiny fragment that exactly exhibited the problem would be very
> helpful, esp. when you have the sort of evil property names such as:
>         sao1239937685
>
> Take home lesson: DIG should be avoided, esp. with datatypes.
>
> Cheers,
> Bijan.
>
>
> ------------
>
> Hi Bijan, Alan,
>
>    I think I just figured out a problem that has plagued me for  
> several months with individuals.  When we have created individuals  
> in the past, we have gotten the error message shown in the  
> screenshot.  However, we have never been able to find an int that  
> is labelled with false.  This has caused us to discard instances in  
> the past in order to get rid of the problem.
>
>    Well today, I went on the assumption that the problem is  
> actually with the booleans themselves.
>
>  <sao:sao1863785805 rdf:datatype=" http://www.w3.org/2001/ 
> XMLSchema#boolean "
>         >false</sao:sao1863785805>
>
>    I've attached an ontology that has booleans in it with false as  
> the value.  When I run it through Pellet using the DIG interface in  
> the latest Protege, it returns the error in the screen shot.   
> However, when I got rid of all the statements with booleans in it,  
> there is no problem, and the ontology checks out just fine.
>
>    Is this a problem with case sensitive 'false' values or  
> something?  At the minimum, I feel that the error message needs to  
> be corrected.  Could you advise me how booleans are supposed to be  
> used?
>
> Thanks,
>    Stephen
> <Pellet-WrongError.png>
> <SAOIndividuals.owl>
> _______________________________________________
> protege-owl mailing list
> protege-owl at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/ 
> faq.html#01a.03




More information about the protege-owl mailing list