Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] SWRL Racer problem

Tania Tudorache tudorache at
Fri Aug 31 14:11:18 PDT 2007


I did try the "compute inferred types" in Protege 3.3.1 (b430) with 
Pellet 1.5 and I did not get any errors. There were some warnings about 
unsupported datatypes in DIG 1.1.

Anyway, I think the DIG converter should probably ignore the swrl 
built-ins. I will talk to Martin about this once he gets back. We are 
also planning on some other fixes for the DIG conversion.


Trina Myers wrote:
> Thank you Samson, 
> Unfortunately this did not fix the problem.
> As a test to show the problem I created 2 new (basic) owl files (attached),
> one with 430 and one using 399. 
> I set up the SWRL tab in both files and imported the SWRL URI's using the
> activate button...The initial owl files were identical except for one line
> in 430: "<owl:ObjectProperty
> rdf:about=""/>" (I did try deleting
> this to see if it was the problem but it made no difference). Also, at this
> stage 'compute inferred types' works. 
> The problems start when I create a rule, in this case I created an empty
> rule in both (as I don't have and classes in either). As soon as I tested
> the 'compute inferred' the 399 version was fine but the 430 version gave the
> error DIG Reasoner Error: Undefined individual
> name|swrlb:addDayTimeDurationToDateTime| in
> ABox|[ID: swrlb:addDayTimeDurationToDateTime]  
> I un-imported the query.owl to no effect.
> I agree it seems to be a problem between Racer and the SWRL but I can not
> see anything anomalous.
> The DIG error messages change sometimes referring to the query.owl,
> sometimes tbox or temporal, the errors seem to be arbitrary - for example,
> the next attempt to do the same thing resulted in the error:
> DIG Reasoner Error: Undefined individual name|tbox:isAnnotationProperty| in
> ABox|[ID: tbox:isAnnotationProperty]
> As soon as I un-import all SWRL ontologies the error messages stop...
> I would be grateful for any help. 
> Cheers
> Trina
> -----Original Message-----
> From: protege-owl-bounces at
> [mailto:protege-owl-bounces at] On Behalf Of Samson Tu
> Sent: Thursday, 30 August 2007 5:50 AM
> To: protege-owl at
> Subject: Re: [protege-owl] SWRL Racer problem
> Hi Trina,
> Martin is on vacation now.
> The error message appears to say that there is some incompatibility between
> RAcer and the SWRL query mechanism that Martin implemented. If you don't use
> SWRL query, can you unimport query.owl and see whether it works?
> Samson
> Trina wrote:
>> Hi Martin and everyone,
>> In a previous post I reported a bug with Racer, SWRLtab and computing 
>> inferred types. Inferring over the ontology is fine using 'compute 
>> inferred types' until I initiate the SWRLtab. Then I get error messages
> like:
>> DIG Reasoner Error: Undefined individual name|query:comumnNames|in 
>> ABox |
>>|[ID: query:columnNames] when computing 
>> inferred types through Racer.
>> I was wondering if you had heard any feedback from this bug report? It 
>> has become a major problem as I can't continue with my research until 
>> I can resolve why this is occurring. I though it might have been an 
>> anomalous glitch in  414 but I have just tested it with the latest 
>> version (430) and the same thing keeps occurring. I have used 3 
>> different machines, I have downloaded RacerPro and Jess again and did a
> clean install for both but still the errors happen.
>> I can send a screenshot showing the problem. One such incident 
>> happened after opeing a new project and creating 2 classes (no 
>> restrictions, instances, etc), setting up the SWRLtab and activating 
>> it. At this stage computing inferred types works fine, however, 
>> anything after this ends in the error message (the screen shot shows a 
>> simple rule is written but not yet sent to the Jess engine). I tried 
>> it using the 'collabborativePizza' ontology supplied with version 430, 
>> after deleting the classes that made it inconsistent I set up the 
>> swrlTab and imported the SWRL ontologies...the error occurred as soon as I
> tried to compute inferred types...
>> I have an old version on one of the machines (399) and the errors do not
> occur??
>> Any suggestions or answers would be extremely appreciated!
>> _______________________________________________
>> protege-owl mailing list
>> protege-owl at
>> Instructions for unsubscribing: 
> ------------------------------------------------------------------------
> _______________________________________________
> protege-owl mailing list
> protege-owl at
> Instructions for unsubscribing: 

More information about the protege-owl mailing list