Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Problems with forms and Protégé versions

Timothy Redmond tredmond at stanford.edu
Wed May 7 15:45:24 PDT 2008


This was surprisingly hard to figure out and it was Tania who got it.   
There are two issues.  The first is that the ontology should use  
UTF-8.  Once this was changed it loaded in Protege 3.4 build 130. I  
attached a UTF-8 version of this owl file.  This is all you need to  
know if you just want to load the file in Protege.

The second issue is that this is a surprisingly good ontology for  
challenging parsers.  The point is that the meta-modelling confuses  
many parsers.  In several cases a datatype property was declared as a  
member of a  meta-class which is a subclass of owl:DatatypeProperty.   
Out of five parsers I tried only two were able to figure out what to  
do with this.  I can send you an alternative version of this ontology  
(with no real changes) that will load in other tools if you need it.

-Timothy



-------------- next part --------------
A non-text attachment was scrubbed...
Name: RCU2_saved.owl
Type: application/octet-stream
Size: 71686 bytes
Desc: not available
URL: <http://mailman.stanford.edu/pipermail/protege-owl/attachments/20080507/cfdbe694/attachment.owl>
-------------- next part --------------


On May 7, 2008, at 4:49 AM, Esther Lozano Hontecillas wrote:
> Hi all,
>
> I've been working with Prot?g? 3.1 and it worked correct, but I  
> decided to update to a new version. I 've tried with Prot?g? 3.3.1  
> and with Prot?g? 3.4 but in both cases I get a consistency problem  
> that I don't have with the 3.1 version. The problem is the next:
>
> In the ontology there are classes webDataProperty and  
> webObjectProperty, that are subclasses of DatatypeProperty and  
> ObjectProperty respectively, and they have properties like for  
> example webRow or webColumn. All the properties of my ontology are  
> instances of one of these classes.
> When I select the Properties tab I can see that some properties have  
> their own properties (webRow, webColumn...) inside a red box (that  
> indicates inconsistency, doesn't it?). This happens with some of the  
> properties and not always in the same way.
> I've noticed in the Form tab that the Widget type of properties like  
> webRow is incorrect, but if I change it, then all the values of this  
> property disappear for all the instances.
>
> I have several ontologies with the same estructure that are being  
> used in a real environment, so to correct the widget types and put  
> the values again one by one is not a very good option.
>
> So, where's the problem? And why it doesn't happen when I open the  
> project with Prot?g? 3.1 version? I'd tried to create the project  
> again for the new version (using the .owl file) but it happens the  
> same.
>
> Thanks in advance,
>
> ________________
> Esther Lozano
> <RCU2.owl>_______________________________________________
> protege-owl mailing list
> protege-owl at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03



More information about the protege-owl mailing list