Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] xml:lang for subproperties of datatype properties (cf. bug 391)

Dennis Spohr dennis.spohr at ling.uni-stuttgart.de
Fri Oct 24 05:55:18 PDT 2008


Hi,

I have a problem that is closely related to bug 391 [1], 
though more grave, I think. I hope it hasn't been posted 
earlier on the list...

I've created a datatype property Prop with range "string" 
and a subproperty SubProp. As reported in [1], the 
MultiLiteralWidget offers me to edit the xml:lang 
attribute only for Prop, but not for SubProp (where it 
offers "type", i.e. the datatype). xml:lang should be 
offered for the subproperty as well, I assume, so this is 
one part of the problem.

In addition to this, if I add a value for SubProp with 
type "string", save the project and reopen it, the value 
does not appear, neither in the file nor in Protege. 
Moreover, if I add a value for SubProp manually in the 
file and then open it in Protege, it also doesn't appear, 
so it seems that the value is generally ignored.

This only happens to values of SubProp: if I add a value 
for
Prop, then save and reopen, the value of Prop appears 
correctly.

Do you have any idea what the problem could be, or how to 
avoid it?

Thanks a lot!
Dennis

[1]
http://smi-protege.stanford.edu/bugzilla/show_bug.cgi?id=391



More information about the protege-owl mailing list