Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Class incompatibility between Protege 3.4.1 binary release and 3.4.1 SVN?

simonpa simon.paradies.ext at siemens.com
Wed Aug 5 01:45:11 PDT 2009


Hi,

I try to connect from a fresh Protégé 3.4.1 installation (binary, from
website) to a Protégé 3.4.1 Server which is built from SVN sources (and
started in eclipse). Everything works until opening the collaboration tab.
Then I get a
java.io.InvalidClassException:
edu.stanford.bmir.protegex.chao.ontologycomp.api.impl.DefaultOntology_Component;
local class incompatible: stream classdesc serialVersionUID =
5604731067330685839, local class serialVersionUID = -6398320490477530252
This suggests a different code base between the SVN version and the release
version from the website. I reverted from the trunk to the 3.4.1 tag for the
protege-core, protege-owl, protege collab, protege rdf-backend, and Protégé
changes project, but still, the error occurs. Any ideas what might be wrong?
Btw. the SVN version of the offending class is 13858.

Thanks
Simon
-- 
View this message in context: http://www.nabble.com/Class-incompatibility-between-Protege-3.4.1-binary-release-and-3.4.1-SVN--tp24823073p24823073.html
Sent from the Protege - OWL mailing list archive at Nabble.com.




More information about the protege-owl mailing list