Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Class incompatibility between Protege 3.4.1 binary release and 3.4.1 SVN?

Timothy Redmond tredmond at stanford.edu
Thu Aug 6 07:19:36 PDT 2009


> My suspicion is that the trouble is hidden somewhere in the  
> complexities of the phrase "and started in eclipse".  Eclipse has  
> many things to keep track of and somewhere something got out of sync.

Another possibility that I forgot about is that the rmiregistry could  
be out of sync.  Sometimes, and I don't think anyone in the stanford  
group knows why, the rmiregistry needs to be restarted in order to  
make the server-client work.  This is one of the things we do when we  
are having trouble.

-Timothy


On Aug 5, 2009, at 10:51 PM, Timothy Redmond wrote:

>
> I was not able to replicate your issue.  I built protege from  
> scratch using the release-3.4.1 tag , ran the server and connected  
> to that server from a Protege 3.4.1 from the downloads page.  I have  
> attached the build run and the logs from the distributed  Protege  
> 3.4.1 client.
>
> My suspicion is that the trouble is hidden somewhere in the  
> complexities of the phrase "and started in eclipse".  Eclipse has  
> many things to keep track of and somewhere something got out of sync.
>
> I admit that I cheated a little on the build.txt file.  I made a  
> couple of mistakes and edited those out.  (In particular standard- 
> extensions had a build file problem that I know I fixed but must not  
> have committed.)  I also connected to the server twice because the  
> first time I thought I lost the logs.
>
> -TImothy
>
>
> <build.txt><protege_3.log>
> On Aug 5, 2009, at 1:45 AM, simonpa wrote:
>
>>
>> Hi,
>>
>> I try to connect from a fresh Protégé 3.4.1 installation (binary,  
>> from
>> website) to a Protégé 3.4.1 Server which is built from SVN sources  
>> (and
>> started in eclipse). Everything works until opening the  
>> collaboration tab.
>> Then I get a
>> java.io.InvalidClassException:
>> edu 
>> .stanford 
>> .bmir.protegex.chao.ontologycomp.api.impl.DefaultOntology_Component;
>> local class incompatible: stream classdesc serialVersionUID =
>> 5604731067330685839, local class serialVersionUID =  
>> -6398320490477530252
>> This suggests a different code base between the SVN version and the  
>> release
>> version from the website. I reverted from the trunk to the 3.4.1  
>> tag for the
>> protege-core, protege-owl, protege collab, protege rdf-backend, and  
>> Protégé
>> changes project, but still, the error occurs. Any ideas what might  
>> be wrong?
>> Btw. the SVN version of the offending class is 13858.
>>
>> Thanks
>> Simon
>> -- 
>> View this message in context: http://www.nabble.com/Class-incompatibility-between-Protege-3.4.1-binary-release-and-3.4.1-SVN--tp24823073p24823073.html
>> Sent from the Protege - OWL mailing list archive at Nabble.com.
>>
>> _______________________________________________
>> protege-owl mailing list
>> protege-owl at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>>
>> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03
>
> _______________________________________________
> protege-owl mailing list
> protege-owl at lists.stanford.edu
> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>
> Instructions for unsubscribing: http://protege.stanford.edu/doc/faq.html#01a.03




More information about the protege-owl mailing list