Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Bug using OWL + DB Backend

Simon Paradies simon.paradies.ext at siemens.com
Tue Mar 31 05:42:55 PDT 2009


Hi Tania,

Using the "Release Version" which can be downloaded from the website, there is 
no problem with neither pizza.owl nor collaborativePizza.owl.
However, starting Protege from eclipse using the the very latest version from 
SVN the problem occurs.
What I meant by "I still can write and read the ontology using direct access 
with the client. But Protege-Server won't load it." is that I tried both, 
client and server Protege to access the onotlogy.
Both times, an exception was raised. Using the client version I still could 
work with the onotlogy whereas the server just did not load it and thus I could 
not choose the project when connecting to the server (project does not show up 
in the login dialog).

So imo there are two possibilities:
1. My eclipse project set up is screwed up somehow (however, except the DB 
issues everything works like a charm)
2. There is a bug in the newest version

To exclude the first, I reverted to the latest head version from tags I could 
find:

project , SVN version I used, tag and svn version to which I reverted
====================================================
protege-chanageManagement 13415 (release-3.4; 13515)
protege-chat 13420 (release-3.3.1; 7426)
protege-collab 13422 (release-3.3.1; 7437 compile errors, used trunk instead)
protege-core 13549 (release-3.4; 13511)
protege-owl 13469 (release-3.4; 13512)
protege-rdf-backend 13327 (release-3.4; 13514)
protege-standard-extensions 13471 (release-3.4; 13513)

However, the problem is still there. Any ideas?

Java: JVM 1.6.0_11-b03, OS: WinXP SP3

Cheers
Simon




More information about the protege-owl mailing list