Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] SWRLTab problems when running protege-owl in eclipse

William Fitzgerald wfitzgerald at 4c.ucc.ie
Sat Apr 3 12:44:24 PDT 2010


Martin,

I want to thank you for your feedback.

Moving forward I will ask an Eclipse expert for advice and will also look into installing it on a
Microsoft machine (to rule out possible Ubuntu issues).

regards,
Will.

Martin O'Connor wrote:
> Eclipse has a multitude of configuration options so it is not always
> possible to figure out issues remotely. I would look for a local Eclipse
> expert to help you.
> 
> Martin
> 
> William Fitzgerald wrote:
>> Hi all,
>>
>> Just a note regarding the ".classpath" file:
>> I see why the the "jess.jar" file does not show up in the ".classpath"
>> file. When I add it as a
>> library to the build path, I see that the ".classpath" file gets the
>> following entry:
>> <classpathentry kind="lib"
>> path="/home/wfitzgerald/workspace/protege-owl/plugins/edu.stanford.smi.protegex.owl/jess.jar"/>
>>
>>
>> Note, I then removed the run configuration classpath entry for the
>> jess.jar file under "User
>> Entries" as it is now placed under "protege-owl (default classpath)".
>>
>> I still get the same Jess rule engine load failure :-(
>>
>> Just one other note, when I installed protege-core I did receive an
>> error regarding the
>> "sun.rmi.server.LoaderHandler". As a result, I edited the "Forbidden
>> Reference (access rules)" in
>> the Eclipse complier "errors and warnings" so that it was considered a
>> warning and not an error. I
>> do not think this has anything to do with my current problem. This
>> issue to my understanding is to
>> do with the protege server.
>>
>> regards,
>> Will.
>>
>> William Fitzgerald wrote:
>>  
>>> Hi Martin,
>>>
>>> I set the classpath in the "run configurations" tab under "User
>>> Entries" to be
>>> "protege-owl/plugins/edu.stanford.smi.protegex.owl/jess.jar".
>>>
>>> Note, I removed the "jess.jar" file from the build path (where I
>>> originally thought it should be,
>>> I'm new to eclipse)
>>>
>>> Eclipse must be working correctly in part, because the console error
>>> messages I get are:
>>>
>>> Jess rule engine load failed: could not find jess.Rete - or an error
>>> occured on initialization
>>>
>>> Plugin 'SQWRLQueryTab' registered with the SWRLTab plugin manager.
>>>
>>> The reason I say that it works in part, is because if I remove the
>>> classpath entry for "jess.jar", I
>>> get the following error for the SQWRLQueryTab:
>>>
>>> SQWRLQueryTab load failed: could not find jess.Rete - or an error
>>> occured on initialization
>>>
>>>
>>> If you think there is something else I am leaving out please let me
>>> know.
>>>
>>> Two more pieces of information:
>>> (1) In the Eclipse "Package Explorer" where I see the project src
>>> files etc the "plugins" directory
>>> does not show the "edu.stanford.smi.protegex.owl" nor the relevant
>>> swrl files and jess.jar file that
>>> I copied into it once I installed the protege-owl project as per wiki
>>> instructions.
>>>
>>> (2) I looked at the ".classpath" file in the "protege-owl" directory
>>> and I see no reference to the
>>> ".jess.jar" file having been added. Perhaps Eclipse has some sort of
>>> bug when running on Ubuntu
>>> Jaunty? I also notice that when I added the "jess.jar" to the
>>> classpath it gets added directly under
>>> "User Entries" and not under "protege-owl (default classpath)" even
>>> though I clicked on that folder
>>> to "Add Jars".
>>>
>>> Below is the ".classpath" file:
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <classpath>
>>>     <classpathentry kind="src" path="src"/>
>>>     <classpathentry kind="con"
>>> path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
>>>
>>>     <classpathentry combineaccessrules="false" kind="src"
>>> path="/protege-core"/>
>>>     <classpathentry kind="lib" path="lib/antlr-2.7.5.jar"/>
>>>     <classpathentry kind="lib" path="lib/arq-extra.jar"/>
>>>     <classpathentry kind="lib" path="lib/arq.jar"/>
>>>     <classpathentry kind="lib" path="lib/axis.jar"/>
>>>     <classpathentry kind="lib" path="lib/commons-discovery-0.4.jar"/>
>>>     <classpathentry kind="lib" path="lib/commons-lang-2.0.jar"/>
>>>     <classpathentry kind="lib" path="lib/commons-logging-1.1.1.jar"/>
>>>     <classpathentry kind="lib" path="lib/concurrent.jar"/>
>>>     <classpathentry kind="lib" path="lib/edtftpj-1.5.2.jar"/>
>>>     <classpathentry kind="lib" path="lib/ekitspell.jar"/>
>>>     <classpathentry kind="lib" path="lib/icu4j_3_4.jar"/>
>>>     <classpathentry kind="lib" path="lib/iri.jar"/>
>>>     <classpathentry kind="lib" path="lib/jcalendar.jar"/>
>>>     <classpathentry kind="lib" path="lib/jdom.jar"/>
>>>     <classpathentry kind="lib" path="lib/jena.jar"/>
>>>     <classpathentry kind="lib" path="lib/jep-2.4.0.jar"/>
>>>     <classpathentry kind="lib" path="lib/json.jar"/>
>>>     <classpathentry kind="lib" path="lib/junit.jar"/>
>>>     <classpathentry kind="lib" path="lib/kazuki.jar"/>
>>>     <classpathentry kind="lib" path="lib/log4j-1.2.12.jar"/>
>>>     <classpathentry kind="lib" path="lib/lucene-core-2.3.1.jar"/>
>>>     <classpathentry kind="lib" path="lib/orphanNodesAlg.jar"/>
>>>     <classpathentry kind="lib" path="lib/owlsyntax.jar"/>
>>>     <classpathentry kind="lib" path="lib/stax-api-1.0.jar"/>
>>>     <classpathentry kind="lib" path="lib/swingx-1.0.jar"/>
>>>     <classpathentry kind="lib" path="lib/wstx-asl-3.0.0.jar"/>
>>>     <classpathentry kind="lib" path="lib/xercesImpl.jar"/>
>>>     <classpathentry kind="lib" path="lib/xml-apis.jar"/>
>>>     <classpathentry kind="output"
>>> path="plugins/edu.stanford.smi.protegex.owl"/>
>>> </classpath>
>>>
>>> Many thanks in advance,
>>> Will.
>>>
>>>
>>> Martin O'Connor wrote:
>>>    
>>>> This sounds like an Eclipse project configuration problem. Have you
>>>> added jess.jar to your execution path for your run configurations? It
>>>> may be different from your built path.
>>>>
>>>> Martin
>>>>
>>>> William Fitzgerald wrote:
>>>>      
>>>>> Dear Experts,
>>>>>
>>>>> I have successfully got protege-OWL to run within Eclipse as described
>>>>> by :
>>>>> http://protege.cim3.net/cgi-bin/wiki.pl?CompileProtegeOWLInEclipse
>>>>>
>>>>> However, I cannot get SWRL to run.
>>>>>
>>>>> I copied the jess.jar file into the
>>>>> "protege-owl/plugins/edu.stanford.smi.protegex.owl" directory
>>>>> and added it as a jar in the Eclipse build path.
>>>>>
>>>>> Note I had to use the "Add External Jars" option in Eclipse as it
>>>>> complained about an output
>>>>> directory when I tried to use the "Add Jars" option. The complaint
>>>>> was:
>>>>> "Cannot nest
>>>>> 'protege-owl/plugins/...ns/edu.stanford.smi.protegex.owl'"
>>>>>
>>>>> When I create a simple ontology as test, I can add the SWRLTab.
>>>>> However the SWRLTab only has the
>>>>> SQWRL Query Tab icon (top right hand side of SWRLtab) and does not
>>>>> have the rules icon. Note if I do
>>>>> not add the jess.jar using the "Add External Jars" option I will not
>>>>> see the SQWRL Query Tab icon.
>>>>> Note also that, I can create rules and queries I just can not execute
>>>>> them.
>>>>>
>>>>> On clicking the SQWRL Query Tab icon I get the following message:
>>>>> "SWRLJessBridge load failed - could not find class
>>>>> edu.stanford.smi.protegex.owl.swrl.bridge.exceptions.NoRegisteredBridgesException:
>>>>>
>>>>> no registered
>>>>> bridges"
>>>>>
>>>>> I am running Eclipse Galileo on a Ubuntu 9.04 with java version
>>>>> "1.6.0_16"
>>>>>
>>>>> How do I resolve this issue?
>>>>>
>>>>> regards,
>>>>> Will.
>>>>> _______________________________________________
>>>>> protege-owl mailing list
>>>>> protege-owl at lists.stanford.edu
>>>>> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>>>>>
>>>>> Instructions for unsubscribing:
>>>>> http://protege.stanford.edu/doc/faq.html#01a.03
>>>>>
>>>>>           
>>
>>   
> 



More information about the protege-owl mailing list