Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] SWRLTab problems when running protege-owl in eclipse

William Fitzgerald wfitzgerald at 4c.ucc.ie
Tue Apr 6 12:49:06 PDT 2010


Hi Jennifer,

That worked perfectly.

Many thanks,
Will.



Jennifer Vendetti wrote:
> Hi Will,
> 
> This is not an Ubuntu issue as I can reproduce on Windows XP.
> 
> If you want to run SWRL rules, there is a runtime dependency on the
> SWRLJessBridge [1].  Here are some steps you can use to configure
> Eclipse to get this running:
> 
> 1).  Create a new Java project in your Eclipse workspace for
> swrl-jess-bridge.  If you are new to Eclipse, here are some more
> specific instructions for creating the new project:
> 
> a).  Use a repository exploring perspective to look at our Subversion
> repository (http://smi-protege.stanford.edu/repos/protege).
> b).  Right-click on swrl-jess-bridge/trunk and choose Checkout...
> c).  In the resulting "Checkout from SVN" dialog, make sure the "Check
> out as a project configured using the New Project Wizard" radio button
> is selected, and click Finish.
> d).  In the "New Project" dialog, choose Java Project and click Next.
> e).  Give your project a name in the "New Java Project" dialog and click
> Next.
> f).  On the "Java Settings" panel, click the Projects tab.  Add
> protege-core and protege-owl as required projects on the build path. 
> Click Finish.
> 
> 2).  When the swrl-jess-bridge project is initially created, it won't
> compile because it depends on the jess.jar file.  To fix the compile
> errors, you can export the jess.jar file from the protege-owl project. 
> Again, more specific steps are:
> 
> a).  Right click on the protege-owl project to bring up the Properties
> dialog.
> b).  On the Properties dialog, select Java Build Path -> Libraries. 
> Make sure the jess.jar file is one of the libraries on the build path. 
> If it does not appear in the list, you can click the "Add JARs..."
> button to add it to the build path.  (This assumes that you have already
> downloaded the jess.jar file).
> c).  After adding jess.jar to your build path, navigate to the Order and
> Export tab and check the box next to the jess.jar file to export it
> (make it visible to the swrl-jess-bridge project).
> 
> 3).  The last step is to modify your protege-owl runnable to make sure
> it has the jess.jar file on the classpath.  If you bring up the Run
> Configurations dialog and go to the Classpath tab for the protege-owl
> runnable, you can select User Entries and click the "Add Projects..."
> button to add the swrl-jess-bridge project that you created in previous
> steps.
> 
> At this point, you should be able to run protege-owl from Eclipse and
> execute your SWRL rules.  If you have completed everything successfully,
> you should see the following messages in your console:
> 
> Rule engine 'SWRLJessBridge' registered with the SWRLTab bridge.
> Plugin 'SWRLJessTab' registered with the SWRLTab plugin manager.
> Plugin 'SQWRLQueryTab' registered with the SWRLTab plugin manager.
> 
> Hope this information helps.
> 
> Best,
> Jennifer
> 
> [1] http://protege.cim3.net/cgi-bin/wiki.pl?SWRLJessBridge
> 
> 
> On 4/1/2010 4:38 AM, William Fitzgerald wrote:
>> Dear Experts,
>>
>> I have successfully got protege-OWL to run within Eclipse as described
>> by :
>> http://protege.cim3.net/cgi-bin/wiki.pl?CompileProtegeOWLInEclipse
>>
>> However, I cannot get SWRL to run.
>>
>> I copied the jess.jar file into the
>> "protege-owl/plugins/edu.stanford.smi.protegex.owl" directory
>> and added it as a jar in the Eclipse build path.
>>
>> Note I had to use the "Add External Jars" option in Eclipse as it
>> complained about an output
>> directory when I tried to use the "Add Jars" option. The complaint was:
>> "Cannot nest 'protege-owl/plugins/...ns/edu.stanford.smi.protegex.owl'"
>>
>> When I create a simple ontology as test, I can add the SWRLTab.
>> However the SWRLTab only has the
>> SQWRL Query Tab icon (top right hand side of SWRLtab) and does not
>> have the rules icon. Note if I do
>> not add the jess.jar using the "Add External Jars" option I will not
>> see the SQWRL Query Tab icon.
>> Note also that, I can create rules and queries I just can not execute
>> them.
>>
>> On clicking the SQWRL Query Tab icon I get the following message:
>> "SWRLJessBridge load failed - could not find class
>> edu.stanford.smi.protegex.owl.swrl.bridge.exceptions.NoRegisteredBridgesException:
>> no registered
>> bridges"
>>
>> I am running Eclipse Galileo on a Ubuntu 9.04 with java version
>> "1.6.0_16"
>>
>> How do I resolve this issue?
>>
>> regards,
>> Will.
>> _______________________________________________
>> protege-owl mailing list
>> protege-owl at lists.stanford.edu
>> https://mailman.stanford.edu/mailman/listinfo/protege-owl
>>
>> Instructions for unsubscribing:
>> http://protege.stanford.edu/doc/faq.html#01a.03
>>    



More information about the protege-owl mailing list