Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] Problems with repository

Rita Marnau rma at informatik.uni-kiel.de
Wed Aug 4 07:52:05 PDT 2010


Hi,

I create a new Ontology for a protege plugin and would like to add a 
global repository entry for this ontology.
Situation:  I create a plugin-ontology when the plugin starts the first 
time. plugin-ontology.repository is created with all needed import paths.
I add a global repository entry:

LocalFolderRepository localRepository = new LocalFolderRepository(
                     repositoryFile, true)
plugin-ontology.getRepositoryManager().addGlobalRepository(localRepository); 


But every time I load my protege plugin, protege can not find the 
repository and asks for it. Although the .repository file exists with 
every entry needed (in the same directory of the project and the 
plugin-ontology  file).
The repository entry is not shown in the global repository manager 
either. What can I do? The task is that protege finds the repository 
itself on loading the plugin without asking the user each time.

I am using Protege 3.4.4 on Windows.  Thanks for help.


Rita
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.stanford.edu/pipermail/protege-owl/attachments/20100804/2f1bec3f/attachment.html>


More information about the protege-owl mailing list