Search Mailing List Archives

Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

[protege-owl] DL Query not showing individuals

Timothy Redmond tredmond at
Thu Nov 11 10:36:14 PST 2010

Update to the latest and you will see the behavior that you are 
expecting.  Previously the inferred individuals only included the 
directly inferred individuals - it excluded the individuals in 
subclasses.  You see a similar thing with subclasses.  Asking for the 
subclasses of Thing does not show C1.


On 11/11/2010 10:08 AM, Jorge Gomes wrote:
> Hi,
> I am having some problems using DL Query.
> In DL Query tab, I check the "Subclasses" and "Individuals" 
> checkboxes. But when I enter the query, sometimes only the classes 
> show up, and not the invididuals of those classes.
> For example:
> I have an individual A, initially asserted of type Thing.
> Then I have class C, which has the subclasses C1 and C2.
> The individual A is inferred as being of type C1. Obviously, it is 
> also inferred as being of type C.
> But if I enter the query "C", it only shows the classes C1 and C2, and 
> not the individual A.
> Although, if I enter the query "C1" the individual A shows up.
> Am I doing something wrong?
> Here is an ontology with this example: 
> Thanks,
> Jorge Gomes
> _______________________________________________
> protege-owl mailing list
> protege-owl at
> Instructions for unsubscribing:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the protege-owl mailing list