Search Mailing List Archives


Limit search to: Subject & Body Subject Author
Sort by: Reverse Sort
Limit to: All This Week Last Week This Month Last Month
Select Date Range     through    

errors on currently configured webauth machine

Thomas Carlson tec at stanford.edu
Thu Dec 10 16:49:43 PST 2015


Hi all,

I just started seeing some errors on a machine configured with webauth.

/webauth-status show's "OK" for most items.

This is suspect though even though I've checked that apache has 
permission to read ...

Service Token Cache read/write check: ok
Service Token info:
     service_token is NULL. This usually indicates a permissions problem 
with the service token cache and/or keytab file .

The apache error_log shows this ...

[Thu Dec 10 16:28:20 2015] [error] mod_webauth: cannot read service 
token cache /var/lib/webauth/service_token_cache: error reading from 
file (/var/lib/webauth/service_token_cache is empty)
[Thu Dec 10 16:28:20 2015] [error] mod_webauth: curl_easy_perform: 
error(35): error:0D0890A1:asn1 encoding routines:ASN1_verify:unknown 
message digest algorithm
[Thu Dec 10 16:28:20 2015] [error] mod_webauth: mwa_get_service_token: 
couldn't get new service token from webkdc
[Thu Dec 10 16:28:20 2015] [emerg] mod_webauth: mwa_get_service_token 
FAILD!!
[Thu Dec 10 16:28:20 2015] [emerg] mod_webauth: redirect_request_token: 
no service token, denying request
[Thu Dec 10 16:28:20 2015] [warn] mod_webauth: failure_redirect: no URL 
configured

FYI: webauth on this machine was built from source.

Any pointers would be much appreciated.

Best, Thomas



More information about the webauth-info mailing list